Like Tree201Likes

NOVAROSSI Engine thread....

Reply

Old 12-15-2010, 12:47 PM
  #751  
Tech Prophet
iTrader: (96)
 
houston's Avatar
 
Join Date: Sep 2004
Location: Sherwood,OR
Posts: 15,828
Trader Rating: 96 (100%+)
Default

Originally Posted by bohdi View Post
I am running buggy and prefer a 7inch pipe (I know, that is what she said)
the 2039 I hear is more of a top end pipe similar to 086 but wondering on the 2035.
9853ss/41021!!!

2035 sucks on nova engines for one and its no coincedence that novarossi pipes work awesome on novarossi engines

good pipes other than novarossi for novarossi

2013 , 086hs dynamite , 053mr dynamite , jp racing 2032 (awesome) , jp-4 or jp-6 , msr/bullit 1005 , the old thunder tiger 2035 pipe works fairly well , there are more but thats what i can think of at the moment

the jp-3 works fairly well but i dont much like the feel of the pipe and nova engines usually dont get great runtime with this pipe
houston is offline  
Reply With Quote
Old 12-16-2010, 04:37 AM
  #752  
Tech Regular
iTrader: (8)
 
davet323's Avatar
 
Join Date: Jun 2010
Location: Australia
Posts: 316
Trader Rating: 8 (100%+)
Default nova +4

Giday Guys

I have a nova +4 with 41021man and 9901 pipe
I have trouble starting when hot it is fine starting when its cold.
Real hard to start if i give throttle when trying to start or if pit guy put finger over pipe to try give more fuel.
I find the only way to get started when warm or hot is to trim throttle 3 or 4 clicks and bump start on box 2 or 3 sec at a time for 10 or more times. But this still takes lots of tries to get it going (if flames out in race it pretty much allover as it take forever too get it going again)

If you know what i mean. (i am fairly new to this rc game)

and i am using rb5 plug as cant get nova plugs from LHS.

So can anyone out there able to help me with this problem
P.S would odonnell 97t be better?

cheers thanks in advance.

Dave
davet323 is offline  
Reply With Quote
Old 12-16-2010, 04:41 AM
  #753  
Tech Elite
iTrader: (235)
 
teamlosi906's Avatar
 
Join Date: Oct 2009
Location: up michigan
Posts: 2,610
Trader Rating: 235 (100%+)
Default

Originally Posted by davet323 View Post
Giday Guys

I have a nova +4 with 41021man and 9901 pipe
I have trouble starting when hot it is fine starting when its cold.
Real hard to start if i give throttle when trying to start or if pit guy put finger over pipe to try give more fuel.
I find the only way to get started when warm or hot is to trim throttle 3 or 4 clicks and bump start on box 2 or 3 sec at a time for 10 or more times. But this still takes lots of tries to get it going (if flames out in race it pretty much allover as it take forever too get it going again)

If you know what i mean. (i am fairly new to this rc game)

and i am using rb5 plug as cant get nova plugs from LHS.

So can anyone out there able to help me with this problem
P.S would odonnell 97t be better?

cheers thanks in advance.

Dave
How much run time on the motor? Sounds like low compression. 97tplug works great!!
teamlosi906 is offline  
Reply With Quote
Old 12-16-2010, 04:45 AM
  #754  
Tech Regular
iTrader: (8)
 
davet323's Avatar
 
Join Date: Jun 2010
Location: Australia
Posts: 316
Trader Rating: 8 (100%+)
Default

giday
nah pretty new about 2 -3 gallens.. comp is pretty good i think
davet323 is offline  
Reply With Quote
Old 12-16-2010, 04:49 AM
  #755  
Tech Elite
iTrader: (235)
 
teamlosi906's Avatar
 
Join Date: Oct 2009
Location: up michigan
Posts: 2,610
Trader Rating: 235 (100%+)
Default

Originally Posted by davet323 View Post
giday
nah pretty new about 2 -3 gallens.. comp is pretty good i think
What temps are you running,might be running to hot I would try the 97T plug first. Im sure Monty will help you out. And what carb insert are you using
teamlosi906 is offline  
Reply With Quote
Old 12-16-2010, 04:51 AM
  #756  
Tech Regular
iTrader: (8)
 
davet323's Avatar
 
Join Date: Jun 2010
Location: Australia
Posts: 316
Trader Rating: 8 (100%+)
Default

Originally Posted by teamlosi906 View Post
What temps are you running,might be running to hot I would try the 97T plug first. Im sure Monty will help you out. And what carb insert are you using
6.5 insert and around 100c in temp
davet323 is offline  
Reply With Quote
Old 12-16-2010, 06:00 AM
  #757  
Tech Elite
iTrader: (18)
 
revo61's Avatar
 
Join Date: Jun 2006
Location: In the dirty south
Posts: 2,883
Trader Rating: 18 (95%+)
Default

You have a air leak somewhere.
revo61 is offline  
Reply With Quote
Old 12-16-2010, 07:28 AM
  #758  
Tech Regular
 
Join Date: Dec 2009
Location: Athens,Greece
Posts: 303
Default

some help from a nova guru?(em. houston? )
http://www.rctech.net/forum/offroad-...g-17011-a.html
the_winner is offline  
Reply With Quote
Old 12-16-2010, 12:03 PM
  #759  
Tech Addict
iTrader: (27)
 
Join Date: Jan 2009
Posts: 711
Trader Rating: 27 (100%+)
Default

Hello all...I have a plus 4 with about a gallon and a half on it. I cant seem to find the right spot on it. Its either rich or bonkers power. Im also seeing some wetness around the front bearing. My needle setting are about 1 turn out from flush on the bottom and a lil in from flush on the top. Is my front bearing shot or is my bottom to fat? Have a feeling the bearing is fine and im just running my bottom to fat...anyone have a good baseline?. Thanks
mist467 is offline  
Reply With Quote
Old 12-16-2010, 12:30 PM
  #760  
Tech Regular
 
Join Date: Dec 2009
Location: Athens,Greece
Posts: 303
Default

Originally Posted by the_winner View Post
some help from a nova guru?(em. houston? )
http://www.rctech.net/forum/offroad-...g-17011-a.html
mr Houston can you ''clear'' the topic and solve my/our problem about the 17011 bearing from novarossi. Nova have a new bearing 7x19x6x6.3? or all of the years the nova had the same bearing?because my engine have different bearing from this which i receive
the_winner is offline  
Reply With Quote
Old 12-20-2010, 05:14 AM
  #761  
Tech Regular
iTrader: (6)
 
Join Date: Feb 2009
Posts: 458
Trader Rating: 6 (100%+)
Default toro nero flameout

hi all, i have just broken in a toro nero team edition and ran it in our local race track. engine running ok during the heats but flameout 2x during a 25min finals. it happens at the same spot. wen im going wot on the straight,release throttle, brake and make a sharp right hairpin turn the engine has a tendency to flameout. the fuel tank was not full when this happens.when i blip the throttle a few times along the long stretch it tends not to flameout. the straight stretch is bout 40m. im running on byron 25pct odonnel 097t and thunder tiger 2035.
rossham46 is offline  
Reply With Quote
Old 12-20-2010, 05:23 AM
  #762  
Tech Elite
iTrader: (18)
 
revo61's Avatar
 
Join Date: Jun 2006
Location: In the dirty south
Posts: 2,883
Trader Rating: 18 (95%+)
Default

Do you have a mbx6 or D8 buggy? Check the fuel line and tank.
revo61 is offline  
Reply With Quote
Old 12-20-2010, 05:50 AM
  #763  
Tech Elite
iTrader: (74)
 
aussies1129's Avatar
 
Join Date: Jun 2007
Location: LAND DOWN UNDER
Posts: 3,485
Trader Rating: 74 (100%+)
Default

Originally Posted by davet323 View Post
Giday Guys

I have a nova +4 with 41021man and 9901 pipe
I have trouble starting when hot it is fine starting when its cold.
Real hard to start if i give throttle when trying to start or if pit guy put finger over pipe to try give more fuel.
I find the only way to get started when warm or hot is to trim throttle 3 or 4 clicks and bump start on box 2 or 3 sec at a time for 10 or more times. But this still takes lots of tries to get it going (if flames out in race it pretty much allover as it take forever too get it going again)

If you know what i mean. (i am fairly new to this rc game)

and i am using rb5 plug as cant get nova plugs from LHS.

So can anyone out there able to help me with this problem
P.S would odonnell 97t be better?

cheers thanks in advance.

Dave
hey Dave get your self some odonnell plugs I am running the 77t in both my
+4 engine and ran the 97t in my previous +4, sounds like you have an air leak is your engine still running very rich even at race temp? give this a try take off your carb put some sealant around the outside of the throat if you have lucky 7 use that if no get locktite gasket sealant its red and not cheap but will seal it up good. you can put some on your backplate if you like. go back to factory settings on your needles and retune from there oh and change your plug to one of the above and you should see some results.
cheers
aussies1129 is offline  
Reply With Quote
Old 12-20-2010, 06:48 AM
  #764  
Tech Regular
iTrader: (6)
 
Join Date: Feb 2009
Posts: 458
Trader Rating: 6 (100%+)
Default

Originally Posted by rossham46 View Post
hi all, i have just broken in a toro nero team edition and ran it in our local race track. engine running ok during the heats but flameout 2x during a 25min finals. it happens at the same spot. wen im going wot on the straight,release throttle, brake and make a sharp right hairpin turn the engine has a tendency to flameout. the fuel tank was not full when this happens.when i blip the throttle a few times along the long stretch it tends not to flameout. the straight stretch is bout 40m. im running on byron 25pct odonnel 097t and thunder tiger 2035.
im running on a hyper 9
rossham46 is offline  
Reply With Quote
Old 01-20-2011, 11:34 PM
  #765  
Tech Regular
iTrader: (6)
 
Join Date: Feb 2009
Posts: 458
Trader Rating: 6 (100%+)
Default

hi all , wil a jp3 or rb 2045 perform better in a toro nero. im using it for a truggy.
rossham46 is offline  
Reply With Quote

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service