Go Back  R/C Tech Forums > General Forums > Radio and Electronics
Tekin Rx8 Gen3 Thread >

Tekin Rx8 Gen3 Thread

Like Tree78Likes

Tekin Rx8 Gen3 Thread

Old 03-24-2021, 04:27 AM
  #376  
Tech Initiate
 
Join Date: Jan 2021
Location: texas
Posts: 35
Default

I did get some real info from Tekin yesterday, he stated it is the reboot code which could be from overcurrent on the BEC. Which I put a new servo in earlier that day which happened to be a HV servo and I did not change my BEC to 7.4VDC. There is a very good chance that is what is happening. I am going to head out to the shop in a bit and try that.
txrocks is offline  
Old 03-24-2021, 05:52 AM
  #377  
Tech Apprentice
 
Join Date: Mar 2021
Posts: 84
Default

Originally Posted by txrocks View Post
I did get some real info from Tekin yesterday, he stated it is the reboot code which could be from overcurrent on the BEC. Which I put a new servo in earlier that day which happened to be a HV servo and I did not change my BEC to 7.4VDC. There is a very good chance that is what is happening. I am going to head out to the shop in a bit and try that.
A high voltage servo does not necessarily have to run 7.4v and will not correct the issue.
Shawn B is offline  
Old 03-24-2021, 07:42 AM
  #378  
Tech Elite
 
morgoth's Avatar
 
Join Date: May 2010
Location: Belgium
Posts: 2,923
Default

My RX8 Gen3 died on Sunday. It started suddenly cogging like a phase that's disconnected. I went home and replaced my cables, thinking that a cable was damaged. The issue stayed and I tried an other motor. But same thing with that one.
I always used with a Kyosho Zeal gel under it, so I tried to protect it as good as possible
morgoth is offline  
Old 04-04-2021, 07:55 PM
  #379  
Tech Initiate
 
Join Date: Jan 2021
Location: texas
Posts: 35
Default

Originally Posted by Shawn B View Post
A high voltage servo does not necessarily have to run 7.4v and will not correct the issue.

Update on mine. Changing the BEC to 7.4vdc fixed the problem. It was the only thing I changed and it's been fat dumb and happy since.
txrocks is offline  
Old 04-22-2021, 07:07 PM
  #380  
Tech Rookie
 
BWtekno83's Avatar
 
Join Date: Apr 2021
Location: Washington
Posts: 2
Default

Originally Posted by morgoth View Post
My RX8 Gen3 died on Sunday. It started suddenly cogging like a phase that's disconnected. I went home and replaced my cables, thinking that a cable was damaged. The issue stayed and I tried an other motor. But same thing with that one.
I always used with a Kyosho Zeal gel under it, so I tried to protect it as good as possible
same problem here. Iím trying to figure out what caused my esc to fail. Any idea what caused it?
BWtekno83 is offline  
Old 04-29-2021, 12:42 AM
  #381  
Tech Elite
 
morgoth's Avatar
 
Join Date: May 2010
Location: Belgium
Posts: 2,923
Default

Originally Posted by BWtekno83 View Post
same problem here. I’m trying to figure out what caused my esc to fail. Any idea what caused it?
Nope, I always took good care of it. The only thing I can see is that some of the coating of the PCB at the bottom wore off. The support for the PCB look too thin and maybe they cut into the PCB.
Tekin offered me to replace it for 129$, but I'm in the EU. I need to ship back to the USA first, then they ship to me and I have to pay customs on it. All shipping costs and customs are for me, so it will be almost as expensive as a new unit bought locally.
The new XR8 Pro combo is half the price of the Tekin combo over here, so I bought that now. That will hurt less if it dies
I must say the HW combo is a lot smoother than my Tekin RX8 Gen 3 with 1900kv Gen 3 motor. But the thing I liked so much about Tekin is that it doesn't need a fan for buggy use.
morgoth is offline  
Old 06-16-2021, 09:52 AM
  #382  
Tech Rookie
 
Join Date: Jun 2021
Posts: 2
Default

Does anyone have the values for the light tree when programing? The directions only give a few, but not for break strength, drag break, and a few others. Thanks
Chasebanks is offline  
Old 06-16-2021, 02:54 PM
  #383  
R/C Tech Elite Member
iTrader: (7)
 
lowspark's Avatar
 
Join Date: Oct 2013
Location: Dallas, TX
Posts: 615
Trader Rating: 7 (100%+)
Default

Originally Posted by Chasebanks View Post
Does anyone have the values for the light tree when programing? The directions only give a few, but not for break strength, drag break, and a few others. Thanks
search YouTube 'Tekin Clinic'. There are 24 videos where Randy explains all the different settings and how to program them on the unit...
lowspark is offline  
Old 06-17-2021, 01:07 PM
  #384  
Tech Regular
 
Join Date: May 2019
Posts: 268
Default

Brief read over and just wanted to double check a few points on the RX8 Gen3

1) 12 awg is perfectly suitable for power and motor wires? I normally default to 10 awg on my 4S bashers but the solder post would be a little cluttered trying to wire up 10 awg

2) as it doesnít run ĎLipo auto-detectí I can just wire up an LiHV with no need to change settings

3) Iíve seen a few comments about leaving the HW3 connected but as it uses the fan port wouldnít that meant they have removed the fan or powered it separately? Assuming you canít run a splitter?

4) Iíve been able to set the RX8 via my iPhone and HW3 but can never get a connection when using my PC, I just keep getting a Ďcheck connectioní error given the HW3 works via BT Iím I right in assuming the error is most likely related to my PC setting up?

Thanks
EvilR2.0 is offline  
Old 06-17-2021, 01:33 PM
  #385  
Tech Master
iTrader: (17)
 
Join Date: Oct 2007
Location: The States
Posts: 1,796
Trader Rating: 17 (100%+)
Default

#1 Tekin uses 12ga posts and fit 12ga wire
#2 does not auto select voltage cut off thou is customizable, 4s must be selected even for lihv.
#3 the fan only needs a +5vdc and ground from the fan plug, modification at your own risk.
EvilR2.0 likes this.
Juglenaut is online now  
Old 08-30-2021, 10:05 AM
  #386  
Tech Initiate
 
Join Date: Sep 2020
Posts: 28
Default

Has anyone replaced the case on this? Are there instructions anywhere? Bought a black replacement case and there is zero documentation, nor is there any on the Tekin site that I can find.
jkranz is offline  
Old 08-30-2021, 10:20 AM
  #387  
Tech Rookie
 
Join Date: Oct 2020
Posts: 3
Default

Originally Posted by jkranz View Post
Has anyone replaced the case on this? Are there instructions anywhere? Bought a black replacement case and there is zero documentation, nor is there any on the Tekin site that I can find.
I replaced the white case with the black one on mine and it was fairly straightforward. I removed the bottom screws and gently pulled it out. You will need to un-solder the wires.
acpowell is offline  
Old 08-30-2021, 11:21 AM
  #388  
Tech Initiate
 
Join Date: Sep 2020
Posts: 28
Default

Thanks... I had removed the screws (nothing yet soldered) and it reallllly did not want to come out, to the point where I was more worried about breaking something more than anything. I'll give it another go and decide if it's worth swapping the cases.
jkranz is offline  
Old 08-30-2021, 01:06 PM
  #389  
Tech Master
iTrader: (17)
 
Join Date: Oct 2007
Location: The States
Posts: 1,796
Trader Rating: 17 (100%+)
Default

Originally Posted by jkranz View Post
Thanks... I had removed the screws (nothing yet soldered) and it reallllly did not want to come out, to the point where I was more worried about breaking something more than anything. I'll give it another go and decide if it's worth swapping the cases.
It may be a little snug when cool or cold as the conformal coating and glues used soften a bit after the first use. Some cases if new or used the pcb maybe just adhered a bit to the case.
Juglenaut is online now  
Old 09-14-2021, 08:42 PM
  #390  
Tech Master
 
TurnNBurn's Avatar
 
Join Date: Aug 2001
Location: Miami, FL
Posts: 1,564
Default

Hey Prez, I hear that Jared Tebo is a free agent for some electronics - since Ty is a huge fan of Tekno (saw the first part of the EB48 2.0 Build tonight), it might make for a good match - just sayiníÖ
TurnNBurn is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.