R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Like Tree28Likes
Reply
 
Thread Tools Search this Thread
Old 06-04-2014, 09:10 PM   #2896
Tech Rookie
 
Join Date: Apr 2014
Posts: 16
Default

Quote:
Originally Posted by the incubus View Post
Not if you use Durango's Green Gear Grease Part # TDR390017

This stuff is amazing and it sticks to the gears like white on rice.

http://www.amain.com/product_info.ph...go-Gear-Grease
Thats what i used. Had some left over from my desc210
Zenbot is offline   Reply With Quote
Old 06-04-2014, 10:35 PM   #2897
Tech Addict
 
Rasheed's Avatar
 
Join Date: Jun 2008
Location: Portland, OR
Posts: 678
Trader Rating: 5 (100%+)
Default Parts?

is there any official word of what happened to the parts?

All of my backordered parts on tower changed to mid June, except a few that now say "on order"

I assume that "on order" means they have no idea when they will get them.

Did anyone get parts yet? I guess I should just fire an order from england. I really want to sell my kyosho but I am keeping it so I am not out of commission from a broken part.

On the bright side I've had 2 practice days and 2 race days without anything breaking so I will just knock on wood and keep my fingers crossed!
__________________
Derek "The Speed" Rasheed - Sponsored by Kaiser Permanente. Thrive!

davesrctracks.net - a great offroad 1/10th scale track.
Rasheed is offline   Reply With Quote
Old 06-04-2014, 11:43 PM   #2898
Tech Addict
 
Join Date: Feb 2010
Posts: 533
Trader Rating: 11 (100%+)
Default

What do I do if my kit did not come with rear outer hing pins?????
LT FAB is offline   Reply With Quote
Old 06-05-2014, 05:59 AM   #2899
Tech Elite
 
lbenton's Avatar
 
Join Date: Aug 2012
Location: Fort Worth Tx
Posts: 2,132
Trader Rating: 48 (100%+)
Default

Quote:
Originally Posted by LT FAB View Post
What do I do if my kit did not come with rear outer hing pins?????
Honestly, dig in your trash can... I had no wheel nuts on my kit when I built it. But they turned up in the trash can. Good chance that you just shuffled them out like I did my missing parts.
lbenton is offline   Reply With Quote
Old 06-05-2014, 06:48 AM   #2900
Tech Regular
 
kdeleon's Avatar
 
Join Date: Nov 2009
Location: Chicagoland, IL
Posts: 429
Trader Rating: 10 (100%+)
Default

Quote:
Originally Posted by LT FAB View Post
What do I do if my kit did not come with rear outer hing pins?????
Did you call HPI support? I had a bearing that didn't have the plastic dirt shield and they sent me a new one from Tower. This might be more delayed due to parts availability or maybe that is where all the parts went and are being held for support issues.
kdeleon is offline   Reply With Quote
Old 06-05-2014, 12:50 PM   #2901
Tech Fanatic
R/C Tech Elite Subscriber
 
Join Date: Oct 2010
Posts: 948
Trader Rating: 4 (100%+)
Default

Quote:
Originally Posted by the incubus View Post
My source says definitely.
Agreed
__________________
Jason Snyder

Check out my "YouTube" channel
www.youtube.com/shortcourseworld
Jason Snyder is offline   Reply With Quote
Old 06-05-2014, 04:50 PM   #2902
Tech Adept
 
Join Date: Apr 2013
Posts: 153
Default

Thanks all for an alternative grease info.

Need to find Moly grease thicker than 60. Just hope someone at the counter knows
braderb is offline   Reply With Quote
Old 06-05-2014, 06:42 PM   #2903
Tech Master
 
Join Date: Feb 2010
Location: Valley Cottage NY
Posts: 1,798
Trader Rating: 48 (100%+)
Default

I need some help on piston selection. I run on low traction very bumpy track. I've been running ty OCRC setup but I feel the car is not stable enough.
__________________
Thanks to my sponsors:
My Credit Card
Speedychris22 is offline   Reply With Quote
Old 06-05-2014, 06:58 PM   #2904
Tech Addict
 
Join Date: Feb 2010
Posts: 533
Trader Rating: 11 (100%+)
Default

I went through the trash multiple times to no avail plus I am very meticulous on my builds so I doubt I lost it but you never know . Can you give me the info on who exactly I need to contact to get an issue like this handled?QUOTE=lbenton;13313898]Honestly, dig in your trash can... I had no wheel nuts on my kit when I built it. But they turned up in the trash can. Good chance that you just shuffled them out like I did my missing parts.[/QUOTE]
LT FAB is offline   Reply With Quote
Old 06-05-2014, 07:23 PM   #2905
Tech Elite
 
Teufel Racing's Avatar
 
Join Date: Jan 2008
Location: Sparks Nv.
Posts: 2,134
Trader Rating: 26 (100%+)
Default

Quote:
Originally Posted by LT FAB View Post
I went through the trash multiple times to no avail plus I am very meticulous on my builds so I doubt I lost it but you never know . Can you give me the info on who exactly I need to contact to get an issue like this handled?QUOTE=lbenton;13313898]Honestly, dig in your trash can... I had no wheel nuts on my kit when I built it. But they turned up in the trash can. Good chance that you just shuffled them out like I did my missing parts.
[/QUOTE]

No I doubt you lost it too, though I do think you'll retire on that build. LOL.

Torrance has posted up here quite a bit, he'd for sure be one to get in touch with. Not sure if you have to go through Hobbico/GP or HPI/Hotbodies to get it fixed. Either way, you really need to get that build done. The track demands it. LOL.

I'd try this:
https://www.hpiracing.com/en/support
__________________
J.Mikoliczyk

ZX6 - RB6 - MP9e
Fantom Racing, Cheater Racing
Houston's Engine Service
Teufel Racing is offline   Reply With Quote
Old 06-05-2014, 07:24 PM   #2906
Tech Regular
 
kdeleon's Avatar
 
Join Date: Nov 2009
Location: Chicagoland, IL
Posts: 429
Trader Rating: 10 (100%+)
Default

Quote:
Originally Posted by LT FAB View Post
I went through the trash multiple times to no avail plus I am very meticulous on my builds so I doubt I lost it but you never know . Can you give me the info on who exactly I need to contact to get an issue like this handled?
http://www.hpiracing.com/help

I called them and they handled it on the spot and made the order. Just have the part number ready. They will look it up and basically order it from Tower for you.
kdeleon is offline   Reply With Quote
Old 06-05-2014, 10:02 PM   #2907
Tech Regular
 
ridgeback's Avatar
 
Join Date: Nov 2012
Location: West Coast
Posts: 257
Trader Rating: 13 (100%+)
Default 14mm wheel hexes?

I currently have a ton of cash invested in wheels and tires that are 14mm hexes. This D413 has 12mm; so my question is has anyone tried the XB4 or DEX410 hexes on this axle? I would be a happy camper if I could make my current wheels and tires work (once my D413 finally shows up).
ridgeback is offline   Reply With Quote
Old 06-06-2014, 07:13 AM   #2908
Tech Adept
 
Join Date: Jul 2011
Posts: 126
Default

Quote:
Originally Posted by braderb View Post
Thanks all for an alternative grease info.

Need to find Moly grease thicker than 60. Just hope someone at the counter knows
60 is the percentage of moly in the grease, not thickness or viscosity

http://www.ebay.com/itm/Genuine-Pro-...e0792c&vxp=mtr
Cygnus X is offline   Reply With Quote
Old 06-06-2014, 12:15 PM   #2909
Tech Rookie
 
Join Date: Sep 2012
Location: Norway
Posts: 15
Default

Quote:
Originally Posted by ridgeback View Post
I currently have a ton of cash invested in wheels and tires that are 14mm hexes. This D413 has 12mm; so my question is has anyone tried the XB4 or DEX410 hexes on this axle? I would be a happy camper if I could make my current wheels and tires work (once my D413 finally shows up).
A clubmate of mine uses Xray 14mm hex and dremeled out the slot abit so he is able to use the wheels from his xray
fjelltorsk is offline   Reply With Quote
Old 06-06-2014, 06:58 PM   #2910
Tech Regular
 
Join Date: Jul 2012
Location: Eastern Michigan
Posts: 317
Trader Rating: 23 (100%+)
Default D413 new build pic and question

Hi all- Just got the buggy put together today and ran a few test laps on our indoor track. Silly question but how do I install the front plastic body piece? Do I need to remove the front shock tower to slide it in?

I used the Associated X-Rings ASC91493 for the shock seals. The shocks are very plush and smooth. I used 35F/30R

Also, I am not sure I installed the rear hinge pin holders correctly. I tried to make them flow with the underside of the chassis angle so I assume they are correct but does anyone have a closeup pic? The manual was not very clear for the front or rear.

I left the front sway bar off for now and used the copper on the rear but I think I need to install a front to smooth out the front steering. It is incredibly twitchy.



__________________
--- ---
------

Last edited by scteonoffroad; 06-06-2014 at 07:25 PM.
scteonoffroad is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 5 (0 members and 5 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 08:39 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net