Like Tree2Likes

"the engine tuning bible"

Old 01-28-2020, 01:29 PM
  #511  
Tech Adept
 
FOXSHOXRACING's Avatar
 
Join Date: Nov 2019
Location: If there's racing, i'll be there.
Posts: 136
Talking

This was very helpful and very detailed, thanks for putting this together.
FOXSHOXRACING is offline  
Old 03-16-2020, 07:47 AM
  #512  
Tech Regular
iTrader: (6)
 
Join Date: Jul 2011
Posts: 493
Trader Rating: 6 (100%+)
Default

The link won’t work anymore. Anyone else having this issue?
xlrsd is offline  
Old 04-05-2020, 09:08 PM
  #513  
Tech Adept
 
FOXSHOXRACING's Avatar
 
Join Date: Nov 2019
Location: If there's racing, i'll be there.
Posts: 136
Default

Mine has had issues too. idk why.
FOXSHOXRACING is offline  
Old 04-20-2020, 05:56 PM
  #514  
Tech Initiate
 
Join Date: Jan 2016
Posts: 48
Default

Long post...thanks in advance.

Looking for advice, here is the situation, please critique/tell me what to try/do differently:
northeast: temps around 50 degrees, low humidity

Mito 4: purchased used. P3 plug, byrons gen 2. no modification that i know of to the engine. Clutch/clutch shoes and springs are fresh, as is clutch bell. Good end play. Break in method:
4 tanks on the box, heat gun and head warmer to keep temps 220ish. piston BDC, cooled each time, etc.
4 tanks figure 8's 1/2 throttle ish
left settings at factory (3.5 turns out HSN, 5 turns out LSN, didn't touch mid needle), idle gap set at .6ish, really I just listen to it when I start the engine, adjust to make sure it doesn't flame out but wheels stay still

Tuning:
heat motor with heat gun to about 200
run around parking lot for about 3-4 minutes to get engine temp up with head warmer however difficult to do given temperature and needle settings
lean HSN out 2 hours, full throttle, lots of smoke
lean HSN out another 2 hours: still a little smoke, engine sounds good
car returns to a high idle, not worried because I haven't touched LSN yet
next, lean LSN 2 hours. car still a little sluggish at start, lots of smoke, doesn't quite spin tires
lean LSN another 1-2 hours, still a little smoke, good acceleration. Car at this point is running pretty strong on throttle throughout, no bogging but also not cutting out. Also not pinging as soon as I get off full throttle. fuel in pinch and engine is cutting out around 4 seconds.

where the problems come in...I then lower the idle speed screw. Engine still loading up on fuel, high idle. When I hit the throttle to clear, sometimes it does, sometimes it doesn't
do a couple full speed passes like this and the idle is still hanging long after, I then richen the HSN an hour or so thinking it's a little too lean on top...idle still hangs though.
when I lower the idle screw further it will come down, however sometimes when I clear it out by htting the throttle it stalls.

any help is appreciated. Thanks
JerseyGTS is offline  
Old 06-09-2020, 04:34 PM
  #515  
Tech Initiate
 
Yelreppa's Avatar
 
Join Date: Jan 2019
Location: Bolton uk
Posts: 42
Default Should I start from default settings

This is my first nitro car in 20 years and bought a built kit agama with a novarossi bt7 am at the point now we're I've started on the box to make sure everything is working.
Should I reset needles to factory settings or just tune from what I have see what it does once warm. As I know having a rich set up to start better for the engine.
Man when I heard the thing fire 🔥 up what amazing sound and the smell yessss.
Yelreppa is offline  
Old 06-16-2020, 05:56 PM
  #516  
Tech Rookie
 
blue is better's Avatar
 
Join Date: May 2017
Posts: 4
Default Email me please

Originally Posted by RJNicholson View Post
+1 I have this in PDF form and read it quite often. A must have document for anyone that is running Nitro.

RIP Ron Paris your the man!!
Hey champion would be able to email me the pdf for that info please.
[email protected]
blue is better is offline  

Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.