RJ Speed LTO

Reply

Old 04-24-2017, 09:45 AM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Apr 2017
Posts: 5
Default RJ Speed LTO

A couple of questions for some of you carpet racers and fellow RJ Speed owners. I recently decided to got back into racing on carpet which I never did before. I put together a LTO for a Busch series class. It runs good but I just cant seem to get a handle on the handling. It wheel hops like crazy in the turns. I've tried springs in the front, adjusting differential and the T-bar. Nothing seems to make a difference. Any help or suggestions. Thanks
RookieBomber is offline  
Reply With Quote
Old 04-25-2017, 10:23 AM
  #2  
Moderator
iTrader: (21)
 
MarkA's Avatar
 
Join Date: Aug 2001
Location: Corvallis, OR
Posts: 9,156
Trader Rating: 21 (100%+)
Default

You'd probably have better luck re-posting your question here or here. Very few oval racers in this section of the forum.
MarkA is offline  
Reply With Quote
Old 04-25-2017, 05:54 PM
  #3  
Tech Rookie
Thread Starter
 
Join Date: Apr 2017
Posts: 5
Default

Thanks I'll give it try. New to the forums and really consider myself a rookie after several year break in the action and to dumb to figure it out myself.
RookieBomber is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service