Go Back  R/C Tech Forums > General Forums > Radio and Electronics
4 PKS glitching.....? >

4 PKS glitching.....?

4 PKS glitching.....?

Old 05-04-2012, 12:02 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Jul 2009
Posts: 11
Default 4 PKS glitching.....?

Hello guys.... Ive been using 4 PKS for about 1,5 years. I want to share my experience with this radio.
Yesterday when I was trying to change the model, the receiver's led was off. I've change the rcvr and esc with the new one, but still no response at all. Its really sad. And this happened for the first time.
Do anybody hv same experience with me?
Thks.
denyrusli is offline  
Old 05-09-2012, 07:36 PM
  #2  
Tech Adept
iTrader: (4)
 
RCMICK's Avatar
 
Join Date: Jan 2012
Location: CHICAGO
Posts: 105
Trader Rating: 4 (100%+)
Default

I have a problem with mine and 4 other guys that I know 2. Mine the throttle stays on at about 60% or the brake no neutral. 2 guys sent them back and paid 60 bucks and futaba fixed it. Mine is only 2 months old. So they do it for free. Sucks when you buy a 500 radio and have problems...
RCMICK is offline  
Old 05-11-2012, 08:52 AM
  #3  
Tech Adept
iTrader: (3)
 
simptek's Avatar
 
Join Date: Dec 2010
Location: ATL GA
Posts: 211
Trader Rating: 3 (100%+)
Default

Originally Posted by RCMICK View Post
I have a problem with mine and 4 other guys that I know 2. Mine the throttle stays on at about 60% or the brake no neutral. 2 guys sent them back and paid 60 bucks and futaba fixed it. Mine is only 2 months old. So they do it for free. Sucks when you buy a 500 radio and have problems...

I am having the same issue with mine right now. but its intermittent. It happens every now and then. At first I thought it was my ESC until I started messing around with my Nitro buggy with the same result. Any idea what it is?
simptek is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.