Go Back  R/C Tech Forums > General Forums > Radio and Electronics
Power-capacitor problem (LRP Sphere) >

Power-capacitor problem (LRP Sphere)

Power-capacitor problem (LRP Sphere)

Old 07-03-2008, 12:18 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Apr 2007
Location: Sweden-Stockholm
Posts: 13
Default Power-capacitor problem (LRP Sphere)

Hello guys! I bought a LRP Sphere ESC & Vector 5.5T combo from Amainhobbies. When I got it out of the package BOTH cables to the power-capacitor was loose! Because the power-capacitor didn't have any marks(+/-) I went to a electronics shop to get a new. I was told it probably is a 4700uF by a guy on another forum but the guy at the electronic shop measured it and said it was only 700uF. He also told me it wouldn't be a problem to have a stronger one. So, he took out the 4700uF 16V but it was LARGE. Then he found a 2200uF 16V with the same diameter as the original. I bought both.

Could 700uF be right? Is it safe to try the 2200uF? What could happen? The 4700uF is BIG.

http://i210.photobucket.com/albums/b...r/IMG_2306.jpg
http://i210.photobucket.com/albums/b...r/IMG_2309.jpg
http://i210.photobucket.com/albums/b...r/IMG_2352.jpg

Best regards
Calle Pledger
Calle Pe is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.