R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road > Onroad Nitro Engine Zone

Reply
 
Thread Tools Search this Thread
Old 07-19-2011, 11:55 AM   #1
Tech Rookie
 
Join Date: Jul 2011
Posts: 4
Default Picco Evo3 factory setting.

Hi All.

Question 1)
I am going to break-in my Picco Evo3 engine.
Please advise the default factory neeedles setting.

Question 2)
Peoples suggest to replace the conrod after break-in. Is it ture?
Can I keep using it for a while after break-in?
Also, how frequent should I replace the conrod?

Question 3)
I can't find picco evo3 conrod in my local store..........
Does picco 4 conrod comparaible to evo4 conrod?

Thank you in advance.

Ray
hpiray is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clockwork Racing Engines and Products... Maximo Offroad Nitro Engine Forum 8424 07-29-2015 03:10 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 02:40 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net