Go Back  R/C Tech Forums > General Forums > Nitro Off-Road
widfire nirto probs(no throttle when press handset) >

widfire nirto probs(no throttle when press handset)

widfire nirto probs(no throttle when press handset)

Old 07-23-2014, 12:23 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Jul 2014
Posts: 1
Default widfire nirto probs(no throttle when press handset)

hi there guys I really need some help,
I just got a wildfire nitro car with 15cxp engine and all worked fine when I picked it up from boy but when got home it started ok but wouldn't work throttle of handset. steering works fine but no brake/throttle, changed battery's and checked connections but nothing
please help.
could it be the servo?
a9racer is offline  
Old 07-23-2014, 03:14 PM
  #2  
Tech Regular
iTrader: (9)
 
rustyfingers's Avatar
 
Join Date: Apr 2011
Location: under your bed
Posts: 381
Trader Rating: 9 (100%+)
Default

Watch the throttle servo when you pull the trigger. Does it move?
No, check servo connections to the receiver first but could be bad throttle servo.
Yes, check the linkages from the server to the engine and brakes. Does the throttle servo center when you turn on the car?

To check the transmitter trigger move the throttle servo to the steering input on the receiver. It should move the wheels when you pull the trigger.
rustyfingers is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.