Help please!!

Old 04-28-2012, 12:09 PM
  #1  
Tech Adept
Thread Starter
 
luke71933's Avatar
 
Join Date: Feb 2012
Posts: 191
Default Help please!!

Hi,
i bought a savox sc 0251 (set up as steering servo on an xray 808 2011 buggy) 2 months ago and it never did good on turning to the left side , now when i steer to one side and then leave it free the wheels do not come straight but stay to the side i last turned.?
Please anyone help.?
luke71933 is offline  
Old 04-28-2012, 12:16 PM
  #2  
Tech Master
 
rcduder's Avatar
 
Join Date: Oct 2011
Location: Tacoma, WA
Posts: 1,124
Default

Originally Posted by luke71933 View Post
Hi,
i bought a savox sc 0251 (set up as steering servo on an xray 808 2011 buggy) 2 months ago and it never did good on turning to the left side , now when i steer to one side and then leave it free the wheels do not come straight but stay to the side i last turned.?
Please anyone help.?
make sure your steering is freed up and its not getting caught on anything i mean the littlest thing will stop it from moving back on its own
rcduder is offline  
Old 04-28-2012, 01:17 PM
  #3  
Tech Rookie
 
robert j's Avatar
 
Join Date: Apr 2012
Location: torquay, devon ,uk
Posts: 7
Default

Check settings on your remote there prob not set properly,I had the same prob on my buggy.messed
Around with it now works fine.
robert j is offline  
Old 04-28-2012, 01:50 PM
  #4  
Tech Apprentice
iTrader: (5)
 
Join Date: Jan 2012
Location: boise, idaho
Posts: 98
Trader Rating: 5 (100%+)
Default

Also check your steering wheel in your transmitter. My wheel wad binding and causing me lots of trouble a lot like that. Always sticking randomly to one side or another. I actually had to use a body reamer and ream out the transmitter shell to free up the steering wheel. That problem drove me nuts! Took apart the whole front end of my mbx6r about three times till I figured that out.
klopsided6r is offline  
Old 04-28-2012, 02:40 PM
  #5  
Tech Adept
Thread Starter
 
luke71933's Avatar
 
Join Date: Feb 2012
Posts: 191
Default

I know i need to set it up but it never gets good i tried lots of different combinations but never gets back to the normal free position the wheels stay on one side, the wheel is not jammed.
luke71933 is offline  
Old 04-29-2012, 02:33 AM
  #6  
Tech Adept
Thread Starter
 
luke71933's Avatar
 
Join Date: Feb 2012
Posts: 191
Default

i changed the batteries of the remote and everything it seems that when my steering is free(wheels in the middle) it is staying steered to the right i think there is something with the servo saver because from the remote trim i cant get any more.
luke71933 is offline  
Old 04-29-2012, 02:44 AM
  #7  
Tech Master
iTrader: (15)
 
JoePit's Avatar
 
Join Date: Mar 2012
Location: Phoenix, AZ
Posts: 1,278
Trader Rating: 15 (100%+)
Default

My friends car had same issues this week. Internal gears took a crap. If your car steers fine on the stand and barely moves when you drop it on the ground it's more than likely your internal gears.
JoePit is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.