R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 02-16-2005, 07:26 AM   #331
Tech Adept
 
Sgt_Morrow's Avatar
 
Join Date: Dec 2004
Location: Paragould Ar
Posts: 128
Default

Pics of my Buggy so far
Attached Images
File Type: jpg mike\'s pics 001.jpg (146.2 KB, 239 views)
Sgt_Morrow is offline   Reply With Quote
Old 02-16-2005, 07:26 AM   #332
Tech Adept
 
Sgt_Morrow's Avatar
 
Join Date: Dec 2004
Location: Paragould Ar
Posts: 128
Default

2
Attached Images
File Type: jpg mike\'s pics 002.jpg (139.4 KB, 196 views)
Sgt_Morrow is offline   Reply With Quote
Old 02-16-2005, 07:27 AM   #333
Tech Adept
 
Sgt_Morrow's Avatar
 
Join Date: Dec 2004
Location: Paragould Ar
Posts: 128
Default

3
Attached Images
File Type: jpg mike\'s pics 003.jpg (141.6 KB, 182 views)
Sgt_Morrow is offline   Reply With Quote
Old 02-16-2005, 07:28 AM   #334
Tech Adept
 
Sgt_Morrow's Avatar
 
Join Date: Dec 2004
Location: Paragould Ar
Posts: 128
Default

4
Attached Images
File Type: jpg mike\'s pics 004.jpg (154.1 KB, 208 views)
Sgt_Morrow is offline   Reply With Quote
Old 02-16-2005, 11:03 AM   #335
Tech Elite
 
Aaron Waldron's Avatar
 
Join Date: Apr 2004
Location: Escondido, CA
Posts: 3,720
Default

It's too pretty, go drive it!
__________________
Aaron Waldron - LiveRC
www.liverc.com
Aaron Waldron is offline   Reply With Quote
Old 02-16-2005, 11:29 AM   #336
Tech Regular
 
Sofast-NT's Avatar
 
Join Date: Sep 2004
Location: North Carolina
Posts: 462
Default

Yea, my jammin loooked like that for about 2days, it had its first race Sat. I couldn't believe how well car handled, placed second.

Sofast-NT is offline   Reply With Quote
Old 02-16-2005, 05:47 PM   #337
Tech Adept
 
Sgt_Morrow's Avatar
 
Join Date: Dec 2004
Location: Paragould Ar
Posts: 128
Default

I just got to put my RB S7 II on JP 1 pipe and servos and paint my bod and ill be ready to RIP
Sgt_Morrow is offline   Reply With Quote
Old 02-16-2005, 10:45 PM   #338
Tech Elite
 
Aaron Waldron's Avatar
 
Join Date: Apr 2004
Location: Escondido, CA
Posts: 3,720
Default

Rebuilding my car for the Nitro Challenge..give it a good shake down tomorrow and it's ready to take down some big names next week!
__________________
Aaron Waldron - LiveRC
www.liverc.com
Aaron Waldron is offline   Reply With Quote
Old 02-17-2005, 04:15 PM   #339
Tech Fanatic
 
bigl's Avatar
 
Join Date: Jul 2004
Posts: 919
Trader Rating: 31 (100%+)
Default

Aaron is the fuel filter derectional and if so which way does it go
bigl is offline   Reply With Quote
Old 02-17-2005, 04:19 PM   #340
Tech Regular
 
Join Date: Dec 2004
Location: PA
Posts: 311
Trader Rating: 8 (100%+)
Send a message via AIM to MMor101
Default

Oring goes towards the engine.
MMor101 is offline   Reply With Quote
Old 02-17-2005, 06:50 PM   #341
Tech Elite
 
arghh's Avatar
 
Join Date: Jan 2005
Location: asean
Posts: 2,583
Default

why i cannot get the perfect ride height using standard blue spring on the front absorber. look like the spring is too stiff and the ride height is too high..?? have to adjust from the lower arm limiter

Last edited by arghh; 02-17-2005 at 08:00 PM.
arghh is offline   Reply With Quote
Old 02-17-2005, 07:42 PM   #342
Tech Elite
 
Aaron Waldron's Avatar
 
Join Date: Apr 2004
Location: Escondido, CA
Posts: 3,720
Default

Well, what ride height are you looking for? I'm running the stock blue springs and haven't found them to be too stiff or too long.

Maybe something else is bound up? Are your shock shafts in the right shocks (fronts in the front shocks, etc.)? Are your shock ends threaded on all the way?
__________________
Aaron Waldron - LiveRC
www.liverc.com
Aaron Waldron is offline   Reply With Quote
Old 02-17-2005, 08:32 PM   #343
Tech Elite
 
arghh's Avatar
 
Join Date: Jan 2005
Location: asean
Posts: 2,583
Default

what i want is the normal ride height - arm level
this is a 2'nd hand x1cr pro and it comes like that. the ride height is very high above the arm level. there is no issue when i use ofna 9.5 standard black spring
arghh is offline   Reply With Quote
Old 02-17-2005, 10:40 PM   #344
Tech Elite
 
Aaron Waldron's Avatar
 
Join Date: Apr 2004
Location: Escondido, CA
Posts: 3,720
Default

Are the rear springs on the front shocks? The springs are different lengths and that's the only thing I can think of that would cause that. I'm using the stock blue springs and my preload nuts are about 6-7 threads from the top of the shock body, and my car sits at or just below arms level.

I'll figure this out if it kills me..don't get discouraged. Haha
__________________
Aaron Waldron - LiveRC
www.liverc.com
Aaron Waldron is offline   Reply With Quote
Old 02-18-2005, 12:30 PM   #345
Tech Adept
 
Sgt_Morrow's Avatar
 
Join Date: Dec 2004
Location: Paragould Ar
Posts: 128
Default

What is the stock camber and toein-toe out for the Jammin buggy
Sgt_Morrow is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Jammin/Hongnor X1 - so close yet so far jono mad racer Nitro Off-Road 5 05-08-2011 06:40 AM
anybody close ????? slowpokeRRR Minnesota and North/South Dakota Racing 0 08-24-2007 10:21 PM
close please pwnzor R/C Items: For Sale/Trade 0 06-29-2007 12:40 PM
close Big B R/C Items: For Sale/Trade 0 02-02-2007 10:29 PM
please close racenut123 R/C Items: For Sale/Trade 1 04-30-2003 05:08 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 12:54 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net