Needing help

Old 08-26-2016, 02:32 PM
  #1  
Tech Regular
Thread Starter
iTrader: (14)
 
FlintstoneF1yer's Avatar
 
Join Date: Nov 2006
Location: Illinois
Posts: 471
Trader Rating: 14 (100%+)
Default Needing help

I've got a castle creation esc (unknown which one) and a 5900 tacon motor (green can) I'm trying to figure out how to link it u. If anyone can help me out that'd be great. Below I'll show pictures of the esc and motor.

Thanks
Attached Thumbnails Needing help-image.jpg  

Last edited by FlintstoneF1yer; 08-26-2016 at 02:36 PM. Reason: Misspelled
FlintstoneF1yer is offline  
Old 08-26-2016, 02:33 PM
  #2  
Tech Regular
Thread Starter
iTrader: (14)
 
FlintstoneF1yer's Avatar
 
Join Date: Nov 2006
Location: Illinois
Posts: 471
Trader Rating: 14 (100%+)
Default

Motor pic
Attached Thumbnails Needing help-image.jpg  
FlintstoneF1yer is offline  
Old 08-26-2016, 02:35 PM
  #3  
Tech Regular
Thread Starter
iTrader: (14)
 
FlintstoneF1yer's Avatar
 
Join Date: Nov 2006
Location: Illinois
Posts: 471
Trader Rating: 14 (100%+)
Default

Esc
Attached Thumbnails Needing help-image.jpg  
FlintstoneF1yer is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.