Go Back  R/C Tech Forums > General Forums > Radio and Electronics
TrackStar Digital servo >

TrackStar Digital servo

TrackStar Digital servo

Old 02-11-2015, 07:06 AM
  #16  
Tech Regular
 
Palebushman's Avatar
 
Join Date: Feb 2014
Location: Queensland, Australia.
Posts: 397
Default

Originally Posted by hackersmovie View Post
Don't mean to rain on any parades here but, 2 bad servos doesn't make them junk or a "rip off"....

I've been using Trackstar ESC's, motors and servos for a while now with only one issue. I had ordered the cheaper TS-D99X for my 2wd buggy and it stripped quick.

Now, Hobbyking's warranty service is AMAZING!
I requested credit to my account and had it within 24 hours. One of my ESC's, the fan didn't work right out of the box, they expressed shipped me a brand new ESC at no charge and I did NOT have to ship the perfectly good ESC back to them!

Say what you will but, with prices and service like that, Trackstar is the biggest home run I've found in the hobby yet.... and I've been in it for 30 years.
You're not wrong there hackersmovie
In my experience, HK can certainly pride themselves on that point.




.
Palebushman is offline  
Old 03-24-2015, 02:00 PM
  #17  
Tech Regular
 
Mopar2Ya's Avatar
 
Join Date: Nov 2014
Posts: 357
Default

How are the TS-9*0 series holding up? Especially the TS-910?
Mopar2Ya is offline  
Old 05-12-2015, 06:30 AM
  #18  
Tech Fanatic
iTrader: (1)
 
Join Date: Oct 2008
Posts: 886
Trader Rating: 1 (100%+)
Default

In January 2015 I bought (9) TS900 servos from Hobby King.

I am building a 30cc gas 3D plane and thought for the money the servos sound so good with there specification.

5 of these servos do not work as they should right out of the box

I have a switching 6v sbec for power. I tested all servos to 6v. 4 of them jitter badly, one stops till you move the servo arm.

It is NOT hobby king but the manufacture of the servos that has let the product come to the public past quality control in this mess.

I am in the process of getting credit from the servos from hobby king.

This has been my experience with track star thus far. The servos I have left work grate, but I hope they don't fail. I will not buy a track star product again.
Tim3 is offline  
Old 05-15-2015, 01:55 PM
  #19  
Tech Regular
iTrader: (14)
 
golgi's Avatar
 
Join Date: Aug 2004
Location: NE
Posts: 480
Trader Rating: 14 (100%+)
Default

I just got a TS900 to put into my 1/8 scale GT car. I haven't had a chance to run the car yet but the servo seems to have a LOT of torque and very good speed. On the bench, it centers perfectly and seems to really nice build quality. The included servo horns are pretty nice as well.

The only thing I've noticed being different on this servo in comparison to my other servos (Radiopost green, Savox, and various Futaba) is that it's very difficult to turn with the power off. But that shouldn't really matter since this is going to serve steering duty.
golgi is offline  
Old 05-16-2015, 06:07 AM
  #20  
Tech Regular
 
Palebushman's Avatar
 
Join Date: Feb 2014
Location: Queensland, Australia.
Posts: 397
Default

Originally Posted by golgi View Post
I just got a TS900 to put into my 1/8 scale GT car. I haven't had a chance to run the car yet but the servo seems to have a LOT of torque and very good speed. On the bench, it centers perfectly and seems to really nice build quality. The included servo horns are pretty nice as well.

The only thing I've noticed being different on this servo in comparison to my other servos (Radiopost green, Savox, and various Futaba) is that it's very difficult to turn with the power off. But that shouldn't really matter since this is going to serve steering duty.
Found that too golgi
I think this is because the servo gear train ratios are very high, so as to achieve the high torque from such a small fast brushless motor. Mine ran really well, both steering and throttle/brake on the JQ I recently sold.


.
Palebushman is offline  
Old 06-05-2015, 04:40 AM
  #21  
Tech Rookie
 
Join Date: Jun 2015
Posts: 1
Default Faulty TS-920

Hello everyone,

I bought TS-920 in 11/14 and I was very satisfied untill recently. I run it in my slash 4x4, but 10 days ago it stopped working, it moves arm only when I push it.
I'm waiting for my warranty now, and if I get replacement I will sell it and buy Savox for sure.
I have ordered Traxxas 6075 just to have spare one, because season begin and I can't drive my model
AlexRipley978 is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2022 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.