R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Radio and Electronics

Reply
 
Thread Tools Search this Thread
Old 04-08-2012, 09:13 AM   #1
Tech Rookie
 
Join Date: Mar 2011
Location: Newport, NC
Posts: 6
Default Electrical issues....RC10

I have an older model RC10 and am having issues......with a fully charged battery pack, plug it in and turn on the remote, i get a humming sound (from what i believe is the speed control), the steering works but no power to the wheels. The speed control LED is blinking red until i hit the throttle it then turns green but nothing. Also sitting still the steering servo is getting input because the steering arm on the servo is moving slightly back and forth. Any ideas here, I am a novice by all means withthis stuff.
rett73 is offline   Reply With Quote
Old 04-08-2012, 09:03 PM   #2
Tech Elite
 
Join Date: Apr 2009
Posts: 3,048
Trader Rating: 17 (100%+)
Default

You may need to calibrate the ESC, or it could be that your motor is no good, I really need more info to help best. What ESC do you have, what radio system, what motor and what battery? It is normal for a servo to hum a little while "hunting" for neutral or dealing with interference, but from any other componet I would suspect the part needs replacing. However, I would not suggest you spend money on any particular part until you get a better idea of the issue.
__________________
This is Hell, Dante. Not your personal fantasy.
burnineyes is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
JConcepts Winter Indoor Nationals 2011...at SmacTrac rripp Kansas/Missouri Racing 369 02-15-2011 11:54 AM
Baghdad Speedway (Camp Liberty, Iraq) KROGOTH Track Locator Forum 31 11-15-2009 03:44 AM
What's THAT smell!? boostfiend Nitro Off-Road 9 05-06-2008 01:26 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 05:26 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net