R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Radio and Electronics

Reply
 
Thread Tools Search this Thread
Old 02-22-2011, 03:16 PM   #1
Tech Rookie
 
Join Date: Feb 2011
Posts: 3
Default Radio troubles

I just bought a XTM XT2 that came with an Airtronics MX-Sport radio. When I was breaking it in I lost all control of the car. At about 40 feet a way I lost steering and breaks and the car nosed into the curb. I kept the breaks applied as I went to retrieve the car and all of a sudden the car went all out. It jumped the curb and went into a wall at full speed. When I got to the car it was functioning normally. The throttle fail safe was even working when I checked it. Does anyone know what happened to my signal?
fastktm51 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio Control Hobbies & Raceway - Waterbury, CT. Scrubb Northeast Racing Forum 30586 02-05-2018 08:21 PM
Radio Operated Cars of Kelowna (R.O.C.K Racing) Dan Boundy Canadian R/C Scene 5438 09-29-2014 10:04 PM
MADRRC (Maryborough & Districts Radio Rallycross Club Oztiger Australian Racing 2033 09-16-2013 03:42 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 07:03 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net