Go Back  R/C Tech Forums > General Forums > Radio and Electronics
Helios Spektrum Module Problem >

Helios Spektrum Module Problem

Helios Spektrum Module Problem

Reply

Old 09-10-2010, 02:23 PM
  #1  
Tech Regular
Thread Starter
iTrader: (7)
 
zrxrxr's Avatar
 
Join Date: May 2010
Location: Michigan
Posts: 433
Trader Rating: 7 (100%+)
Default Helios Spektrum Module Problem

So I bought a helios off here, and It doesn't appear to be working right. He promised to issue me a refund but I want to see if It's just me being stupid. Is the light on the module supposed to be on? All it does it blink once very quick that's all. Also it doesn't respond the pushing the button. What's wrong?
zrxrxr is offline  
Reply With Quote
Old 09-11-2010, 01:35 AM
  #2  
Tech Master
 
kdeselms's Avatar
 
Join Date: Jun 2008
Posts: 1,019
Default

Mine has been on the fritz lately too, when there's a lot of other radios being operated nearby. The light on the back of the module won't light, it simply won't find a signal. I think that light signifies that the module has locked onto a channel and that's what it connects to the receiver with. If the light doesn't come on, the module isn't finding a channel and isn't locking to one.

From the sound of it, the module may just be bad.
kdeselms is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service