Go Back  R/C Tech Forums > General Forums > Radio and Electronics
JR Z650 SERVO PROBLEMS >

JR Z650 SERVO PROBLEMS

JR Z650 SERVO PROBLEMS

Old 08-02-2009, 12:13 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Feb 2009
Location: so cal
Posts: 4
Angry JR Z650 SERVO PROBLEMS

I have gone through 3 of these servos in the past month. is this a problem anyone else is having or do you suspect a problem with my setup?? i was running 1 for steering and 1 for throttle. when the first steering took a crap i went with the 9100s. the same day the throttle went out. i replaced it with another 650 and it lasted 2 runs on the track then went out. they have all done the same thing. they will stop but if you apply pressure you can get them to work again for a min till they go to a neutral possition. then there dead again... thanks for any help
PAIN IND is offline  
Old 08-18-2009, 09:29 PM
  #2  
Tech Master
iTrader: (10)
 
Join Date: Jul 2007
Location: Rossville Ga
Posts: 1,398
Trader Rating: 10 (100%+)
Default

Make you set your endpoints so you not binding the servo. Basically the servo are turning past the points that you steering will turn. Same on throttle. Hope this helps.
bigde2001 is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.