spektrum problem

Reply

Old 10-20-2007, 02:47 AM
  #1  
Tech Regular
Thread Starter
iTrader: (1)
 
Join Date: Dec 2006
Posts: 373
Trader Rating: 1 (100%+)
Default spektrum problem

Every time I unplug my battery to my receiver I have to rebind the receiver for it to work. I thought maybe it was just something with the micro receiver so I did it to one of my old grey receivers and it does the same thing. I dont ever remember having to rebind my radio before when replacing a battery. Am I missing something?

Thanks in advance for your help.
blowpopracer is offline  
Reply With Quote
Old 10-20-2007, 01:57 PM
  #2  
Tech Champion
iTrader: (44)
 
morris's Avatar
 
Join Date: Nov 2005
Location: jersey shore pa
Posts: 5,693
Trader Rating: 44 (100%+)
Default

Originally Posted by blowpopracer View Post
Every time I unplug my battery to my receiver I have to rebind the receiver for it to work. I thought maybe it was just something with the micro receiver so I did it to one of my old grey receivers and it does the same thing. I dont ever remember having to rebind my radio before when replacing a battery. Am I missing something?

Thanks in advance for your help.
i use both set-ups as well and do not have to rebind when changing a battery......prolly an dumb qesution...but are you sure you are binding it right?
morris is offline  
Reply With Quote
Old 10-20-2007, 05:46 PM
  #3  
Tech Regular
Thread Starter
iTrader: (1)
 
Join Date: Dec 2006
Posts: 373
Trader Rating: 1 (100%+)
Default

Yeah I am sure I did it right. I have done this many times before and never had this problem. I even had a friend try it and the same thing happened to him. The only thing I can think of is I just had a antenae repair done by horizon hobbies, Is it possible they could have done something wrong?

If anyone has any ideas I sure would like to hear em.
blowpopracer is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service