Go Back  R/C Tech Forums > General Forums > Nitro On-Road > Onroad Nitro Engine Zone
Newbie needs help !: Kyosho engine will not start. >

Newbie needs help !: Kyosho engine will not start.

Newbie needs help !: Kyosho engine will not start.

Old 09-30-2010, 08:17 AM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Sep 2010
Location: UK
Posts: 1
Default Newbie needs help !: Kyosho engine will not start.

Hi all,

Im new to the world of RC, and have been given an 1/10 scale 4x4 Kyosho GP car. Its a model Ford GT40, fitted with a Kyosho GS11x engine.

The car is full race spec, since the previous owner used to race it at national races in the UK, but that was many yrs ago, and now the car is approx 20yrs old.

For some reason it will not start.
I have stripped the engine down and found lots of sludgy oil in the bottom of the crank case. So i have washed the entire engine with "Carb Cleaner", then put a few spots of Mobil 1 on the main and small ends of the conrod.
The engine appears to be in good condition, but has problems running.
I have fitted a new Glow Plug, and a new GS Starter, and its got fresh 16% Nitro fuel in the tank.
Very rarely it will actually fire and start, but after about 3mins of Idle it will just die. After that point it will not start again.

A local model shop has said the engine has minimal compression, and as such it needs a new engine, or rebuild.

What are your thoughts ?.

The GS11x seems to be very rare. However there are a few GS15 units on ebay. Will these fit ?. I.e. are they the same physical mounting size ?.

Any help you can give in guiding me would be greatly appreciated.

Paul Taylor,
Reading, UK.
Paul_taylor is offline  
Old 10-02-2010, 07:25 AM
  #2  
Tech Regular
iTrader: (9)
 
Join Date: Jan 2008
Location: Round Rock, Texas
Posts: 295
Trader Rating: 9 (100%+)
Default

Originally Posted by Paul_taylor View Post
Hi all,

Im new to the world of RC, and have been given an 1/10 scale 4x4 Kyosho GP car. Its a model Ford GT40, fitted with a Kyosho GS11x engine.

The car is full race spec, since the previous owner used to race it at national races in the UK, but that was many yrs ago, and now the car is approx 20yrs old.

For some reason it will not start.
I have stripped the engine down and found lots of sludgy oil in the bottom of the crank case. So i have washed the entire engine with "Carb Cleaner", then put a few spots of Mobil 1 on the main and small ends of the conrod.
The engine appears to be in good condition, but has problems running.
I have fitted a new Glow Plug, and a new GS Starter, and its got fresh 16% Nitro fuel in the tank.
Very rarely it will actually fire and start, but after about 3mins of Idle it will just die. After that point it will not start again.

A local model shop has said the engine has minimal compression, and as such it needs a new engine, or rebuild.

What are your thoughts ?.

The GS11x seems to be very rare. However there are a few GS15 units on ebay. Will these fit ?. I.e. are they the same physical mounting size ?.

Any help you can give in guiding me would be greatly appreciated.

Paul Taylor,
Reading, UK.
if it will idle for 3 mins that seems like a long time to me its sounds like u are too rich check the glo plug to see if its real wet after u have tried to start it a few times if so theres to much fuel getting in
Roadrash730 is offline  
Old 10-04-2010, 01:31 AM
  #3  
Tech Elite
iTrader: (29)
 
R3VoLuTiOn's Avatar
 
Join Date: Jan 2004
Location: Vancouver, Canada
Posts: 2,702
Trader Rating: 29 (100%+)
Default

unless if you are restoring it to be a collectors item, I wouldnt spend any money on it(replacing engine etc).

If the local shop can't tune it, then you might want to find a local near you who might have a shot at it? Any local tracks or forums you can check out are worth a shot.
R3VoLuTiOn is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.