R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road > Onroad Nitro Engine Zone

Reply
 
Thread Tools Search this Thread
Old 08-27-2009, 06:28 PM   #1
Tech Regular
 
Join Date: Jul 2009
Posts: 320
Exclamation Factory carb settings for Sirio Evo4 STI?!

i replaced my o-rings on all of my needles! now i am stuck and need to know the factory card ssttings for this engine! please help! ThankYou!
LAM3SAUCE is offline   Reply With Quote
Old 08-27-2009, 07:37 PM   #2
Tech Elite
 
Riketsu's Avatar
 
Join Date: Aug 2004
Location: Puerto Rico
Posts: 2,514
Trader Rating: 32 (100%+)
Send a message via AIM to Riketsu
Default

Quote:
Originally Posted by LAM3SAUCE View Post
i replaced my o-rings on all of my needles! now i am stuck and need to know the factory card ssttings for this engine! please help! ThankYou!
Will you please stop opening useless threads that can be asked in their respective threads?

If people don't answer, then ask again nicely. In the same thread.

If no one answers, call Sirio directly or Google it.
__________________
eBay user id: riketsukirai
Riketsu is offline   Reply With Quote
Old 08-27-2009, 10:06 PM   #3
Tech Regular
 
Join Date: Jul 2009
Posts: 320
Default

Quote:
Originally Posted by Riketsu View Post
Will you please stop opening useless threads that can be asked in their respective threads?

If people don't answer, then ask again nicely. In the same thread.

If no one answers, call Sirio directly or Google it.
ok... i am sorry man but i already did all that trust me! i waited weeks to get this answer and no answer! i called kyosho america i called trinity epic, i asked people everywhere i posibly can no answer! i googled it... yahoo... hotmail... everything, i am in a nitro engine thread! what more do you want! i seriousely need the answer and dont need you to monitor me when i post up threads! i tried i tried and tried! why is this becoming such a big deal for! i see plenty of other people asking a similar questions on there engines and nettle setting etc... why are you coming on to me all the time and not them?!
LAM3SAUCE is offline   Reply With Quote
Old 08-28-2009, 06:05 AM   #4
Tech Regular
 
Join Date: Nov 2007
Location: Melbourne,Australia
Posts: 339
Trader Rating: 5 (100%+)
Default

hey mate you try going super fat on the motor like five turns out on the bottom,six on the top dont touch the needle on the back of the motor opposite the low jet and work them in slowly top end first then bottom then idle,make sure your clutch is set up properly,thats a starting point hope it helps,take your time dont rush the tuning teach yourself give the adjustments time to react before making more changes at first you may need to turn a couple of hours on the top needle then go to one hour changes do the same on the bottom also try here http://www.rctech.net/forum/nitro-of...ble.html.enjoy
__________________
ARC R10/2015 - HOBBYWING - PROAMPS - ORCA

BRCCC
elche_83 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 12:55 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net