R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road > Onroad Nitro Engine Zone

Reply
 
Thread Tools Search this Thread
Old 11-28-2008, 12:40 PM   #1
Tech Apprentice
 
Join Date: Oct 2008
Posts: 81
Trader Rating: 24 (100%+)
Default OS Speed Spec 2 Help!

I have a new OS Speed Spec 2 . Leaning out to race settings and the motor will not go back to idle. Stays on high RPM then eventually goes down? I have taken needles out of carp and cleaned, tried different pipes,lengthened both pressure and feed lines. Took carb out and put back made sure all the way down. Big race in < 2 weeks bought this motor for HP and getting real frustrated at this time. Anybody help?
TBO88 is offline   Reply With Quote
Old 11-28-2008, 05:27 PM   #2
Tech Master
 
chippy's Avatar
 
Join Date: Jan 2002
Location: NSW OZ
Posts: 1,492
Trader Rating: 4 (100%+)
Default

Sounds like the bottom is to rich with the combination of the Idle to high.
chippy is offline   Reply With Quote
Old 11-28-2008, 05:29 PM   #3
Tech Apprentice
 
Join Date: Oct 2008
Posts: 81
Trader Rating: 24 (100%+)
Default

I turned the bottom end in and it is worse?
TBO88 is offline   Reply With Quote
Old 11-28-2008, 05:36 PM   #4
Tech Master
 
chippy's Avatar
 
Join Date: Jan 2002
Location: NSW OZ
Posts: 1,492
Trader Rating: 4 (100%+)
Default

Quote:
Originally Posted by TBO88 View Post
I turned the bottom end in and it is worse?
Ok then go the other way out and see if this settles it down quicker.
Is there excess fuel anywhere around the front of the engine if so the front bearing may be gone and need replacing. This can also make the engine run on.
The OS engines are notorious for that.
chippy is offline   Reply With Quote
Old 11-28-2008, 05:41 PM   #5
Tech Apprentice
 
Join Date: Oct 2008
Posts: 81
Trader Rating: 24 (100%+)
Default

No fuel around bearing. It is brand new. I did go fatter, very sluggish in ramping up RPM
TBO88 is offline   Reply With Quote
Old 11-28-2008, 05:45 PM   #6
Tech Rookie
 
MaxTech's Avatar
 
Join Date: Feb 2003
Posts: 13
Default

Quote:
Originally Posted by TBO88 View Post
I have a new OS Speed Spec 2 . Leaning out to race settings and the motor will not go back to idle. Stays on high RPM then eventually goes down? I have taken needles out of carp and cleaned, tried different pipes,lengthened both pressure and feed lines. Took carb out and put back made sure all the way down. Big race in < 2 weeks bought this motor for HP and getting real frustrated at this time. Anybody help?

Your top needle in too Lean backoff 1/4 turn and then try run it hard for 2 mins before tune it again, Spec II has a very sensitive carby so lean it in with small inclement, The Spec II definately dont like to run hot, my engine run best at 95-100C with no shortage of power and runtime. also what pipe you are running with? that is another thing can make the engine ran hot and high idling.
MaxTech is offline   Reply With Quote
Old 11-28-2008, 05:49 PM   #7
Tech Apprentice
 
Join Date: Oct 2008
Posts: 81
Trader Rating: 24 (100%+)
Default

I had a RD logics turbo 3 on, tried a IDM 2607, have a skyline vr12+ on now
TBO88 is offline   Reply With Quote
Old 11-28-2008, 05:58 PM   #8
Tech Rookie
 
MaxTech's Avatar
 
Join Date: Feb 2003
Posts: 13
Default

Quote:
Originally Posted by TBO88 View Post
I had a RD logics turbo 3 on, tried a IDM 2607, have a skyline vr12+ on now
Dont know about the RD logics but the other 2 is not quite suitable for Spec II which I have tried, and the best suited pipe is OS 1050 and Maxpower 2602The Max pipe is run it cooler then OS pipe but both can give you heaps of power and 5mins of runtime.
MaxTech is offline   Reply With Quote
Old 11-28-2008, 06:06 PM   #9
Tech Apprentice
 
Join Date: Oct 2008
Posts: 81
Trader Rating: 24 (100%+)
Default

I do have an OS speed 1040 L52, on our other car. I will try that pipe tomorrow. Did you mean 1040 not 1050? I never heard of a 1050
TBO88 is offline   Reply With Quote
Old 11-28-2008, 06:25 PM   #10
Tech Rookie
 
MaxTech's Avatar
 
Join Date: Feb 2003
Posts: 13
Default

Quote:
Originally Posted by TBO88 View Post
I do have an OS speed 1040 L52, on our other car. I will try that pipe tomorrow. Did you mean 1040 not 1050? I never heard of a 1050
1050 is the new pipe from OS, I think pipe is same with 1040 but different head

yeh 1040 will works but a bit thustier.
MaxTech is offline   Reply With Quote
Old 11-29-2008, 11:42 PM   #11
Tech Adept
 
Mazda614's Avatar
 
Join Date: Jun 2006
Location: Sydney
Posts: 210
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by TBO88 View Post
I have a new OS Speed Spec 2 . Leaning out to race settings and the motor will not go back to idle. Stays on high RPM then eventually goes down? I have taken needles out of carp and cleaned, tried different pipes,lengthened both pressure and feed lines. Took carb out and put back made sure all the way down. Big race in < 2 weeks bought this motor for HP and getting real frustrated at this time. Anybody help?
TBO88,

The 1050 is the best pipe for the Spec 2. As for your tuning problems, HSN should be set at approx 2.5 from closed ( factory standard), this is a good start position. Start with the LSN out approx 3.5 turns from closed and run the engine on the starter box until at temp. The high RPM hang up is caused by the LSN needle too lean, slowly start leaning the LSN needle and observe the RPM coming back to idle, you will soon reach a point were the idle will start to hang up again, then back off 5 mins. The HSN needle can then be leaned but usually no more that 1/2 turn otherwise the engine will start exhibiting the same problem. Tuned correctly these engines are a blast especially with the 1050 pipe, good run time and heaps of mid to top end power.
__________________
OS Speed T1201
Futaba 4PK 2.4Hz
Serpent 748 TQ
M16 Racing Fuels
Mazda614 is offline   Reply With Quote
Old 11-30-2008, 10:32 AM   #12
Tech Apprentice
 
Join Date: Oct 2008
Posts: 81
Trader Rating: 24 (100%+)
Default

I did all that was suggested and still have the problem. The idle seems to come down in steps.If i go out anymore on low end needle engine is flat from low to mid.
TBO88 is offline   Reply With Quote
Old 12-01-2008, 03:25 PM   #13
afm
Tech Master
 
afm's Avatar
 
Join Date: Nov 2003
Location: lima-peru
Posts: 1,807
Default

Quote:
Originally Posted by TBO88 View Post
I did all that was suggested and still have the problem. The idle seems to come down in steps.If i go out anymore on low end needle engine is flat from low to mid.
This is a very tricky symptom with OS carbs but first of all I suggest you go back to factory settings, specially on the LSN needle, than just work around the HSN needle and the idle screw.

When you run it hard and you come into stop the engine seems to have a very high idle and then starts to drop in increments, it is because you have to much fuel left in chamber and engine has to burn it before idling, so try leaning the HSN needle a little at a time while reducing idle speed opening idle screw. It is very tricky, but just be patient until you find the right balance.

Trust me don't fool aroaund to much with LSN. OS carb is different than Nova and Picco carbs.

AFM
afm is offline   Reply With Quote
Old 12-01-2008, 07:10 PM   #14
Tech Rookie
 
MaxTech's Avatar
 
Join Date: Feb 2003
Posts: 13
Default

TBO88, your are in the right track now, Do it as per AFM said and you will have 1 of the fastest engine in your track
MaxTech is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
8T 2.0 polarismaster Nitro Off-Road 15880 02-02-2015 11:31 AM
OS Speed V-Spec II question Frank L Nitro Off-Road 32 05-20-2009 11:50 PM
My second blown OS VSPEC in less then a gallon...WTH TRIPC Nitro Off-Road 33 04-04-2009 07:08 AM
OS Speed drivability hobdog Nitro Off-Road 38 02-16-2009 08:35 AM
GS CUP Malaysia 2008 jets Malaysian R/C Racers 328 07-08-2008 09:40 AM
iRacingWerkz Nitro Fest II @ Turf City(GP Offroad race registration, 29th July 2007) iRacingWerkz Singapore R/C Racers 109 08-02-2007 03:01 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 11:45 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net