R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road > Onroad Nitro Engine Zone

Reply
 
Thread Tools Search this Thread
Old 03-01-2006, 10:00 PM   #1
Tech Rookie
 
Join Date: Mar 2006
Posts: 7
Default a few problems with my .12

hey guys im pretty new to the nitro rc car scene and have been having a few problems...

firstly my rc is a .12, and ive got a few problems with it starting right away, it stalls as soon as i go to take off and after the petrol runs out it doesnt turn back on till i give it a long rest.

whats wrong with it? does anyone have an idea on how i can fix it? i can do pretty much all of the work myself.

i have played with a few of the settings, but ive returned the idle control screw back to stock, and the other one i wouldnt have a clue what to do with.

any help would be appreciated. thanks guys.
SECUR1TY is offline   Reply With Quote
Old 03-01-2006, 10:10 PM   #2
Tech Elite
 
ProudSavageOwnr's Avatar
 
Join Date: Jan 2006
Location: Leboland Sydney NSW
Posts: 2,826
Send a message via MSN to ProudSavageOwnr Send a message via Yahoo to ProudSavageOwnr
Default

get a new glow plug-this should sold the starter removed
turn the screw in the gold tube all the way in and unscrew it 2 3/4 - 3 turns out and u should be ok or take it to your local hobby shop and they should be a bit better help ..... its abit hard over the internet
__________________
FG leopard comp w/Trevor Simpson 28.5 bzm crank
HIP Baja 5sct
AE tc5 3.5t speed monster,Futaba 4pks
Raptor G4 ,Raptor e550,Gaui x5,Mini titan v2,Precision aerobatics bandit 4s monster,Carbon z scimitar Jr 11x
ProudSavageOwnr is offline   Reply With Quote
Old 03-01-2006, 10:36 PM   #3
Tech Rookie
 
Join Date: Mar 2006
Posts: 7
Default

thanks mate, what ill do is take it somewhere and get them to deal with it. its too much of a headache for me.
SECUR1TY is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
b4/t4 problems trdsupra88 Electric Off-Road 12 03-15-2008 10:52 PM
JR Z-1 Problems...need help! pumpkinfish Radio and Electronics 3 10-24-2007 05:31 PM
Problems.. Oasis Chat Lounge 9 01-16-2006 08:41 AM
tc3 one way problems dontfeelcold Australian Racing 7 12-31-2003 04:34 PM
Set Up Problems Griz Australian Racing 5 12-05-2003 12:44 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 01:53 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net