Go Back  R/C Tech Forums > General Forums > Monster Trucks
Exceed MadBeast Help >

Exceed MadBeast Help

Exceed MadBeast Help

Old 01-02-2014, 01:28 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Jan 2014
Posts: 1
Exclamation Exceed MadBeast Help

Hello,
I have an exceed madbeast and am having some problems recently. The engine starts up but quits as soon as i accelerate. Please help me get my truck running.

youtube => /watch?v=BAkLtRRAVOw
vkarpuram is offline  
Old 01-14-2014, 11:39 AM
  #2  
Tech Elite
iTrader: (157)
 
scottgir's Avatar
 
Join Date: May 2010
Location: Manchester, CT
Posts: 2,263
Trader Rating: 157 (100%+)
Default

Give us more details.

Do you still have the stock electronics?
What batteries are you using?
scottgir is offline  
Old 01-15-2014, 06:51 PM
  #3  
Tech Initiate
iTrader: (6)
 
Join Date: Jan 2012
Posts: 48
Trader Rating: 6 (100%+)
Default

You said "recently", so it ran fine in the past? is this a new engine or used? Either way just go back to the stock settings and go from there. You generally want to set your HSN first to get it running and moving. Then you can set your idle and LSN once its warmed up.
Schlong Connery is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.