R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Micro and Mini Scales

Reply
 
Thread Tools Search this Thread
Old 07-10-2011, 12:32 PM   #1
Tech Rookie
 
Join Date: Jul 2011
Location: brown county
Posts: 3
Default mini e-revo problem

ok i have the 1/16 mini e-revo that is brushless and im running two 11.1v 1300mah li-power lipos and it would just instantly flip over on its back when you gave it throttle. last week the servo went bad so i replaced it and now with both lipos at full charge it has hardly any power. any sugestions?
Traxxas_Freak is offline   Reply With Quote
Old 07-10-2011, 01:37 PM   #2
Tech Regular
 
Dan-RC's Avatar
 
Join Date: Jul 2011
Posts: 351
Trader Rating: 4 (100%+)
Default

You may have burned out the motor. Do you hear any clicking on acceleration? Is something binding in the drive train?
Dan-RC is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
1/16th MINI E-Revo Brushless with lipo,s adubaz7 R/C Items: For Sale/Trade 9 04-14-2010 11:48 AM
WTT 2 BRUSHLESS CARS(Vendetta st + TA 18R) FOR 1(mini e-revo, or brushless 1:8) xsxboy R/C Items: For Sale/Trade 7 09-24-2009 01:04 AM
BL CRT.5 or the new BL mini E-Revo dubluv Micro and Mini Scales 12 04-20-2009 02:59 PM


Tags
1/16, mine revo, revo


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 08:04 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net