Strange battery behavior!

 
Old 05-10-2009, 11:09 AM
  #1  
Tech Elite
Thread Starter
iTrader: (5)
 
dangerwr's Avatar
 
Join Date: Sep 2008
Location: Boulder, CO
Posts: 2,245
Trader Rating: 5 (100%+)
Default Strange battery behavior!

Hey guys~

One of my 4s 5000mAh packs is acting funny. It charges just fine and reads perfect when tested. The problem is that the battery has NO punch when I run. I am thoroughly confused for my Hyperion charger does not alert me of any issues either. Any help would be greatly appreciated, thanks!

Last edited by dangerwr; 05-11-2009 at 11:47 AM.
dangerwr is offline  
Old 05-12-2009, 09:15 AM
  #2  
Tech Master
 
JAM MaxAmps's Avatar
 
Join Date: Jun 2007
Location: Nine Mile Falls, WA
Posts: 1,061
Default

Could you be a bit more clear as to what you mean by "No Punch" I'm sorry but that doesn't tell me what it's doing or not doing compared to another pack.

-J
JAM MaxAmps is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.