R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 10-11-2013, 12:45 PM   #1
Tech Rookie
 
Join Date: Nov 2007
Posts: 10
Default Vampire Racing SR1 Plus Timing problems..

Hello guys

I race touringcar 17.5t with timing.
I am driving with the SR1 Plus esc, but haven't been able getting the timing program in the esc work at all.

No matter what I do in the esc, i can't feel anything, have you guys been having more luck than I with the timinig in this esc ?

Thanks
Eyde is offline   Reply With Quote
Old 10-12-2013, 02:47 AM   #2
Tech Adept
 
Join Date: Jan 2008
Location: In a house
Posts: 226
Default

Quote:
Originally Posted by Eyde View Post
Hello guys

I race touringcar 17.5t with timing.
I am driving with the SR1 Plus esc, but haven't been able getting the timing program in the esc work at all.

No matter what I do in the esc, i can't feel anything, have you guys been having more luck than I with the timinig in this esc ?

Thanks
I had to use one at a brca national as my brakes failed on my normal esc,l tried my spare one and it had no go either,but in my buggy its fine so i think it just is not up to it,it seems vampire need to update esc for stock use but dont know if they will
Quietman is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 09:35 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net