R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 01-21-2013, 10:02 AM   #1
Tech Rookie
 
Join Date: Nov 2007
Posts: 17
Trader Rating: 2 (100%+)
Default Speed Passion Reventon S Calibration...

Hi, I've tried to reach out to Speed Passion support and even the FB pages but no ones is responding so hoping someone here can help out.

I'm trying to Calibrate the SP ESC + SP Motor with my Futaba 4PK Super R radio. per instructions, all EPA's are at 100 and trims at 0.

Instructions say to press/hold the "button" on the on/off switch and then turn on the ESC. In my case as soon as I turn on the ESC it starts a constant beep with a click and at every click you can see the motor move slightly enough to just move the pinion/spur. I can leave it like that for more than a minute and it just keeps on beeping.

Without being able to calibrate it, things "seem" ok. But I would really like to know if there's an underlying problem.

Thanks for any feedback or help...
danleb is offline   Reply With Quote
Old 01-21-2013, 10:12 AM   #2
Tech Elite
 
sosidge's Avatar
 
Join Date: Dec 2001
Location: Bristol, UK
Posts: 3,865
Default

The ESC "beeps" by momentarily powering the motor - it has no separate buzzer. It's normal, just calibrate the ESC as the instructions advise.
sosidge is offline   Reply With Quote
Old 01-21-2013, 02:38 PM   #3
Tech Addict
 
Lessen's Avatar
 
Join Date: Jan 2008
Location: Aurora, OH
Posts: 594
Trader Rating: 2 (100%+)
Send a message via MSN to Lessen
Default

Do you mean a constant "tone"?

I recently sent my Reventon S in for warranty. I couldn't get much of any help in the SP thread either.
__________________
"Nothing in the world can take the place of persistence. Talent will not; nothing is more common than unsuccessful men with talent. "
Lessen is offline   Reply With Quote
Old 01-21-2013, 02:56 PM   #4
Tech Master
 
TAMAK's Avatar
 
Join Date: Nov 2008
Posts: 1,952
Trader Rating: 28 (100%+)
Default

Quote:
Originally Posted by danleb View Post
Hi, I've tried to reach out to Speed Passion support and even the FB pages but no ones is responding so hoping someone here can help out.

I'm trying to Calibrate the SP ESC + SP Motor with my Futaba 4PK Super R radio. per instructions, all EPA's are at 100 and trims at 0.

Instructions say to press/hold the "button" on the on/off switch and then turn on the ESC. In my case as soon as I turn on the ESC it starts a constant beep with a click and at every click you can see the motor move slightly enough to just move the pinion/spur. I can leave it like that for more than a minute and it just keeps on beeping.

Without being able to calibrate it, things "seem" ok. But I would really like to know if there's an underlying problem.

Thanks for any feedback or help...
Make Sure 4pk throttle is reversed. And update ALL firmware prior to running. Read manual, as program card procedures have changed. (from prior models)
__________________
TrakPower Speed Equipment / Speed Passion
Serpent Natrix 748 TQ - Nova REX
D413 Reventon 1.1ex 13.5t; AE B6d Laydown Reventon Pro 1.1
DNX408V2-NovaP5, DETC410-Reventon 1.1ex-5.5t MMM
RC10 , RC10GT2- CV-R- SAVOX,
TAMAK is offline   Reply With Quote
Old 01-21-2013, 04:32 PM   #5
Tech Rookie
 
Join Date: Nov 2007
Posts: 17
Trader Rating: 2 (100%+)
Default

It's a constant beep (every second or so).

I can leave it there for over a minute and it just keeps on beeping...

Yes the radio TH is set to reverse.

Other than not being able to calibrate it. It seems to be working fine. Raced it this weekend and performed great. Just want to make sure I'm getting all that it can give...

Also updated to the latest firmware (V20).

Last edited by danleb; 01-21-2013 at 05:11 PM.
danleb is offline   Reply With Quote
Old 01-23-2013, 07:05 PM   #6
Tech Rookie
 
Join Date: Nov 2007
Posts: 17
Trader Rating: 2 (100%+)
Default

Figured it out... Quite embarrassed now...
danleb is offline   Reply With Quote
Old 01-23-2013, 08:03 PM   #7
Tech Addict
 
Cadman1981's Avatar
 
Join Date: Nov 2012
Location: Montreal, Quebec
Posts: 551
Trader Rating: 1 (100%+)
Default

do share!
Cadman1981 is offline   Reply With Quote
Old 01-24-2013, 07:34 PM   #8
Tech Rookie
 
Join Date: Nov 2007
Posts: 17
Trader Rating: 2 (100%+)
Default

I mis-read the instructions where once the ESC was beeping, I needed to press the button again 1 time for Neutral, 1 beep. Then pull full throttle and press again, 2 beeps. Then reverse, press again and 3 beeps. I saw the little "click" image but didn't realize that you had to do it at every step... Duh... One of the Speed Passion guys from the Facebook group figured it out for me...
danleb is offline   Reply With Quote
Old 01-24-2013, 07:56 PM   #9
Tech Champion
 
Join Date: Nov 2002
Location: Chicago, IL
Posts: 7,661
Trader Rating: 37 (100%+)
Default

Quote:
Originally Posted by danleb View Post
I mis-read the instructions where once the ESC was beeping, I needed to press the button again 1 time for Neutral, 1 beep. Then pull full throttle and press again, 2 beeps. Then reverse, press again and 3 beeps. I saw the little "click" image but didn't realize that you had to do it at every step... Duh... One of the Speed Passion guys from the Facebook group figured it out for me...
You are not alone. This is a common mistake that a lot of new users to Speed Passion make. There are usually videos on Youtube of calibrating, wireless modules, and other products they release.

You can watch, pause, and follow along easily.
Nexus is offline   Reply With Quote
Old 04-04-2013, 02:51 AM   #10
Tech Rookie
 
Join Date: Apr 2013
Posts: 2
Thumbs up speed passion reventon s

hey i dunno if anyone can help me , i have a speed passion reventon , i dont have a program card , im using a fs-gt2 remote pretty basic , i have had the speedy for about four days used it once , for around half an hour , change change my tyres over and turned it all back on and now i have no power running to my brushless , unsure on what turn the brushless is , but it was strange for it to work then stop , have tried the "set: button and numerous other trouble shooting so if anyone can help me please let me know
toddywake is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
The Speed Passion Thread memix Electric On-Road 13377 11-28-2017 11:06 PM
Speed Passion Thread kwiksi Radio and Electronics 5727 10-15-2017 06:20 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 05:11 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net