Go Back  R/C Tech Forums > Company/Manufacturer Forums > Ask Hitec
2 servos same problem >

2 servos same problem

2 servos same problem

Old 03-29-2009, 08:29 AM
  #1  
Tech Addict
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Posts: 555
Trader Rating: 1 (100%+)
Default 2 servos same problem

Two 7955 TG's, first one I baught in January and the gears locked up a month later. Second one I baught to replace it gave up in Dallas at the state race last weekend, same problem. EPA's are set correctly on my RC8T and servo saver is set kinda tight. I can still see the front wheels bouncing back and forth in rough terrain though. Have had one in a revo for almost a year now and its been great. Lot of abuse and keeps going. Any thaughts? The two are on there way to you as we speak.
3DRCRACER is offline  
Old 04-01-2009, 11:34 AM
  #2  
Company Representative
 
MikeMayberry's Avatar
 
Join Date: Aug 2001
Location: Poway CA.
Posts: 372
Default

It is not common for the gears to lock up... I would send them in and let us check them out.

Mike.
MikeMayberry is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.