HS-645MG question

Reply

Old 03-27-2008, 12:57 PM
  #1  
Tech Addict
Thread Starter
iTrader: (11)
 
Join Date: Jan 2008
Location: ATL
Posts: 684
Trader Rating: 11 (100%+)
Default HS-645MG question

I currently run this servo as my steering servo in my nitro touring car. One thing I've noticed, it does not center well. I have no binds, bends, or anything. I've tried other servos that are not metal gear or HT, and thy center fine everytime. Is this just a trait of this servo? Or is there something wrong with it? Can I do something about this?
Baedarlboo is offline  
Reply With Quote
Old 03-27-2008, 05:14 PM
  #2  
Company Representative
 
BRENDAN LUGO's Avatar
 
Join Date: Nov 2004
Location: Poway, Ca
Posts: 441
Default

The 645 uses a standard 3 pole motor so it wont center as well as a higher grade servo such as the 9XX series which uses a coreless motor but it should still be good for your general R/C applications. Disconnect the linkage to the servo and test the servo by itself to see if it is centering. If it is not then there may be something wrong with the servo and you can send it in to be checked out. If it does center properly, then there is something else in your setup causing it not to center properly. It could be a bent rod or worn out ball cup or something of that sort.
BRENDAN LUGO is offline  
Reply With Quote
Old 03-30-2008, 12:17 AM
  #3  
Tech Addict
Thread Starter
iTrader: (11)
 
Join Date: Jan 2008
Location: ATL
Posts: 684
Trader Rating: 11 (100%+)
Default

thanks....i'll look into it more...
Baedarlboo is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service