HS5925MG

Reply

Old 12-12-2007, 09:18 PM
  #1  
Tech Initiate
Thread Starter
 
Join Date: Nov 2007
Location: Dayton Ohio
Posts: 32
Default HS5925MG

I have a HS5925NG (Digital)servo in a TC5 and it works GREAT! Last week I did notice it has a small amount of play in it.When turned on you can move the wheels about a 1/16 of a inch,at first I thought it was the servo horn,I replaced it ,didn't help.Is there anything I can do to solve this without replacing it,maybe a repair kit? Gears? This has to be the best servo I have used.All ball cups also replaced, and replaced plastic horn with alum.It's the servo...any help Thanks
8up-racing is offline  
Reply With Quote
Old 12-13-2007, 09:27 AM
  #2  
Company Representative
 
BRENDAN LUGO's Avatar
 
Join Date: Nov 2004
Location: Poway, Ca
Posts: 441
Default

You have a 1/16th inch of movement at the wheels? This dosen't sound like there is a problem with the servo. Metal geared servos have a little bit more gear lash in them than a nylon geared servo. It has to be there so the gears dont bind. If you want to change the gears in the servo, you can get replacement gear sets from your local hobby shop. The part number is #56382
BRENDAN LUGO is offline  
Reply With Quote
Old 12-13-2007, 04:31 PM
  #3  
Tech Initiate
Thread Starter
 
Join Date: Nov 2007
Location: Dayton Ohio
Posts: 32
Default

I will try a gear kit in it.The steering was nice and play free.Now the car wonders alittle on the straight,that is 80ft.long.I kept adjusting the trim.Then I noticed the servo movment. Thank you!
8up-racing is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service