R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 07-06-2005, 11:33 PM   #1
Tech Master
pullstarter's Avatar
Join Date: May 2004
Location: Capital Hill
Posts: 1,466
Trader Rating: 14 (100%+)
Default TB02-R steering problem?

Hey guys, i've just been building up my TB02-R kit and have found that if the steering is setup the way that is illustrated in the instructions i get a VERY minimal steering throw owing to the ball cup jamming against the servo saver when it goes anti-clockwise. Have any of you had this problem? Is there a fix up for this? Any help would be appreciated.

pullstarter is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
TC4 steering problem mnapp69 Electric On-Road 4 12-25-2007 04:20 AM
Steering Problem jmdv Nitro Off-Road 8 06-28-2007 07:23 AM
Steering problem... joe of loath Micro and Mini Scales 5 03-21-2007 12:24 PM
MI2 Steering problem brakkie Electric On-Road 6 02-13-2006 06:01 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 07:47 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0