R/C Tech Forums

R/C Tech Forums (https://www.rctech.net/forum/)
-   Team and Company Discussions (https://www.rctech.net/forum/team-company-discussions-105/)
-   -   Castle Creations Mamba/MM/MMM FACTORY Q&A thread! (https://www.rctech.net/forum/team-company-discussions/136426-castle-creations-mamba-mm-mmm-factory-q-thread.html)

Joe Ford 11-10-2006 10:53 PM

Castle Creations Mamba/MM/MMM FACTORY Q&A thread!
 
1 Attachment(s)
Feel free to ask away gents! Anything and everything! I'll answer what I can!!!

Pic of me sitting in the dual Mamba Max 4600 powered Power Wheels Cadillac Escalade we brought to I Hobby this year. Videos are of the original dual Mamba Max powered Barbie Jeep w/human rider (about 200lbs doing 18mph!), and me playing with the lac for the crowd at the I Hobby show.

http://media.putfile.com/CC-Mamba-Ma...ed-Barbie-Jeep
http://media.putfile.com/Dual-Mamba-...Escalade-video

AETC5 11-11-2006 07:25 AM

1st question. What happened to Shawn Palmer!!!!!!

CRASH 11-11-2006 07:43 AM

I do not believe that this is something that can be discussed. But if it is I am sure Joe will shed some light on it or not.

Later, :)

AETC5 11-11-2006 10:30 AM


Originally Posted by CRASH
I do not believe that this is something that can be discussed. But if it is I am sure Joe will shed some light on it or not.

Later, :)

I was asking Joe, not you. Why do people not in the know always feel the need to comment.

Shawn is a great guy and where ever he goes I am sure will benefit GREATLY! Just odd to see a person of his quality depart from Castle.

CRASH 11-11-2006 03:13 PM

I work at Castle Creations with Joe. Just leaving it up to him to discuss or not discuss this matter.

Thanks, :)

Joe Ford 11-11-2006 08:07 PM

Shawn is no longer with us, we (and I personally) wish him the best, and truly hope he stays in the industry. That's all I can say.

BTW...crash does work w/me @ Castle...here to help, same as myself. :)

Teamcxp 11-14-2006 07:22 AM

Setup Problems
 
I just recently purchased a Mamba Max 5700 system.
I took my time and wired everything correctly and even bought a new spektrum receiver for my T4. The problem I am having is when I go to program the mamba.
I turn the radio on and pull the throttle.
I then turn the switch on
The green light (throttle sets)
Then it switches to the red flashing light and just keeps flashing. It will not set the brake. So I have not even got to set the nuetral either.

The only way I can get it to set is to change my DX2 radio throttle to reverse. Then once I get the esc set Ihave to reverse the throttle on the radio again and it just does not feel very fast at all.

So how can I set this up correctly.
I made sure the plug from the esc to the receivers polarity was correct.
So what am I doing wrong or is there something else I am not aware of?

Thanks,
Mike

jaz 11-14-2006 09:03 AM

Try swapping any 2 of the 3 wires between the ESC and motor. This should reverse the direction the motor turns.

Mike Haynes 11-14-2006 09:06 AM

With the throttle reveresed on the radio, program the speedo and use it normally. It will work right, if you switch it back after programming it will be set wrong.

Teamcxp 11-14-2006 12:15 PM


Originally Posted by rcracingkid
With the throttle reveresed on the radio, program the speedo and use it normally. It will work right, if you switch it back after programming it will be set wrong.

Okay when I reverse the throttle on the radio and program the esc it makes the radio use the brake direction for the gas and the gas direction for the brake on the truck. Once I change the Throttle on the radio back to the normal position it changes the throttle back to the throttle and the brake back to brake like it should be. But it just does not have much power behind it like it should. It feels more like a 19 Turn Spec motor than a good mod motor. This can't be right for the 5700 motor.

Thanks,
Mike

Teamcxp 11-14-2006 12:16 PM


Originally Posted by jaz
Try swapping any 2 of the 3 wires between the ESC and motor. This should reverse the direction the motor turns.

Any Two? Are you sure?



Just a quick question how come this is all necessary, I mean why won't it just set up like the instructions say to set it up? :weird:

Mike Haynes 11-14-2006 12:20 PM

No you are missing the point....just reverse the radio setting...and then set up the esc to be throttle when you pull the throttle. You will not be changing it back.

jaz 11-14-2006 12:33 PM

Yes, switching any 2 wires will reverse the direction of the motor. You'll actually find this in the manual if you look.

Joe Ford 11-15-2006 04:10 AM

Mike...I replied to your email.

All...first thing to do is plug in the battery pack and pull the trigger...see if you get a green LED meaning forward throttle. If not, reverse the throttle on your radio. Next go into endpoint adjustments and max them out...on the DX2 this is 125% throttle/125% brake. If your transmitter has a slide switch to limit the brake (as there is on the DX2...the "A" slider) increase this to it's max as well (125% on the DX2) or it will limit the brake travel. You should then be able to calibrate and program normally. If the wheels spin the wrong direction, swap any two motor wires and the motor will spin the opposite direction. Since the only frictional parts on BL motors are the bearings (which don't care which way they're spinning), there are no side effects of doing this. You can run it in one direction for a year, then swap the wires and run it in the other direction for a year. :) If any of you ever have any problems calibrating your ESC to your transmitter, please give me a call at the # below. I'm more than happy to help. Obviously, have all your gear in front of you. :)

jeffb 11-15-2006 01:57 PM

Joe, Can you tell me the wattage rating of the 7700 system with 6 cells?

Thanks.


All times are GMT -7. It is currently 04:11 AM.

Powered By: vBulletin v3.9.3.6
Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.