Go Back  R/C Tech Forums > General Forums > Electric On-Road > Team and Company Discussions
Castle Creations Mamba/MM/MMM FACTORY Q&A thread! >

Castle Creations Mamba/MM/MMM FACTORY Q&A thread!

Like Tree3Likes

Castle Creations Mamba/MM/MMM FACTORY Q&A thread!

Old 03-28-2008, 05:16 AM
  #1351  
wyd
Tech Legend
iTrader: (51)
 
wyd's Avatar
 
Join Date: Sep 2001
Location: Castle Mamba Max Pro. Feel its power!!!!!!!!!!
Posts: 21,220
Trader Rating: 51 (100%+)
Default

Originally Posted by Lazer Guy
I have a 7700 that I ran all last summer, I never ran the temp over 200* but I had a hard time keeping up with the 3.5's in the straits. I will be running the temp at 220* this year so I can stay in front.


Should I get a new 7700 for this summer because I may have lost some rotor magnetism or will it be at it's best for this year ???



Thank you for making what I believe is the best BL system in the world and the smartest software as well.



7700MambaMax
4600MambaMax
6000MaxAmps
HB Cyclone
HPI pro4
Well I would run it and see how it works for you. Even though the 7700 is capable at running at that temp is still isn't the suggested thing to do but unlike some brands it won't thermal so your good. Might want to put a motor heatsink on to give it a larger cooling area and lower the temps some.

As long as it feels good on the track I wouldn't bother buying another motor other than just to have a spare if you ever need it.
wyd is offline  
Old 03-28-2008, 06:07 AM
  #1352  
Tech Fanatic
iTrader: (1)
 
Join Date: Jun 2007
Location: Adrian, MI
Posts: 823
Trader Rating: 1 (100%+)
Default

wyd..... Thank you for the reply.
Lazer Guy is offline  
Old 03-28-2008, 03:19 PM
  #1353  
Tech Master
iTrader: (32)
 
VenturaDC's Avatar
 
Join Date: Oct 2007
Location: Ventura, SoCal
Posts: 1,133
Trader Rating: 32 (100%+)
Default

Alright, sidewinder 5700, ive ran 4 packs thru it and now all it does is stutter and shake and goes no where and on occasion it will take off for a split second then stop again, never got above 170 in temp, i have good cells to run it, it started doing this halfway thru the last pack i ran, tried a fresh pack still the same. When i switch on the esc it lights up like it used to but it doesnt make the chimes anymore, since the chimes come from the motor im guessing its a motor issue? Anything i can do to check or try to get working?

anyhelp would be great as i was having a blast with it and cant wait to run it some more
VenturaDC is offline  
Old 03-28-2008, 03:32 PM
  #1354  
wyd
Tech Legend
iTrader: (51)
 
wyd's Avatar
 
Join Date: Sep 2001
Location: Castle Mamba Max Pro. Feel its power!!!!!!!!!!
Posts: 21,220
Trader Rating: 51 (100%+)
Default

Originally Posted by Lazer Guy
wyd..... Thank you for the reply.
No problem.
wyd is offline  
Old 03-28-2008, 03:34 PM
  #1355  
Tech Master
iTrader: (27)
 
chewiefttc4's Avatar
 
Join Date: Oct 2006
Location: Bristol tn
Posts: 1,659
Trader Rating: 27 (97%+)
Default

replace the stock bullet connectors and direct solder. this should solve your issues.
chewiefttc4 is offline  
Old 03-28-2008, 03:37 PM
  #1356  
Tech Master
iTrader: (27)
 
chewiefttc4's Avatar
 
Join Date: Oct 2006
Location: Bristol tn
Posts: 1,659
Trader Rating: 27 (97%+)
Default

Originally Posted by Lazer Guy
I have a 7700 that I ran all last summer, I never ran the temp over 200* but I had a hard time keeping up with the 3.5's in the straits. I will be running the temp at 220* this year so I can stay in front.


Should I get a new 7700 for this summer because I may have lost some rotor magnetism or will it be at it's best for this year ???



Thank you for making what I believe is the best BL system in the world and the smartest software as well.



7700MambaMax
4600MambaMax
6000MaxAmps
HB Cyclone
HPI pro4
statistically you wont keep up with the 3.5r. the kv on that motor is 10500 rpm per volt. regear your motor. and get them on the infeild where your car will outpull them outta the corners. time can be made up moreso on the infeild than on the straightaway
chewiefttc4 is offline  
Old 03-28-2008, 05:16 PM
  #1357  
Tech Fanatic
iTrader: (1)
 
Join Date: Jun 2007
Location: Adrian, MI
Posts: 823
Trader Rating: 1 (100%+)
Default

Thank You chewiefttc4........ My 7700 has more rip then the 3.5's so I can pull away going into the strait but our strait have been up to 160+ feet long so thats when there 10500kv gets me,
Thank you for the advice, I will use it.
Lazer Guy is offline  
Old 03-28-2008, 11:16 PM
  #1358  
Tech Master
iTrader: (32)
 
VenturaDC's Avatar
 
Join Date: Oct 2007
Location: Ventura, SoCal
Posts: 1,133
Trader Rating: 32 (100%+)
Default

Originally Posted by chewiefttc4
replace the stock bullet connectors and direct solder. this should solve your issues.

so yea you pretty much ROCK, direct soldered and a fresh batt and not a single problem thanks a million

dc
VenturaDC is offline  
Old 04-05-2008, 07:00 PM
  #1359  
wyd
Tech Legend
iTrader: (51)
 
wyd's Avatar
 
Join Date: Sep 2001
Location: Castle Mamba Max Pro. Feel its power!!!!!!!!!!
Posts: 21,220
Trader Rating: 51 (100%+)
Default

Great job to Castle Creations at the the Mini Nats. Joe you guys did a great job all weekend. Plus had a few beers for me was well. Very nice.

Congrats to Aaron Wilson for making the A main in all 6 classes he ran this year. Awesome!!!!!!!!!!!
wyd is offline  
Old 04-09-2008, 06:25 AM
  #1360  
Tech Adept
iTrader: (1)
 
vinsedprince's Avatar
 
Join Date: Aug 2007
Location: Philippines
Posts: 112
Trader Rating: 1 (100%+)
Default

Joe,

i got the ferrite beads and the stickers!!! thanks!!!
vinsedprince is offline  
Old 04-09-2008, 02:04 PM
  #1361  
Tech Regular
Thread Starter
 
Joe Ford's Avatar
 
Join Date: Nov 2006
Location: Olathe, KS
Posts: 287
Default

You're welcome!

Thanks Brian! Yeah A-ron did awesome at the NATS...why I'm pushing to get him in his very own magazine ad soon.
Joe Ford is offline  
Old 04-09-2008, 04:38 PM
  #1362  
wyd
Tech Legend
iTrader: (51)
 
wyd's Avatar
 
Join Date: Sep 2001
Location: Castle Mamba Max Pro. Feel its power!!!!!!!!!!
Posts: 21,220
Trader Rating: 51 (100%+)
Default

Originally Posted by Joe Ford
You're welcome!

Thanks Brian! Yeah A-ron did awesome at the NATS...why I'm pushing to get him in his very own magazine ad soon.
Nice.
wyd is offline  
Old 04-09-2008, 06:28 PM
  #1363  
Tech Addict
 
Micro-Man's Avatar
 
Join Date: Aug 2007
Posts: 551
Default

I didn't do all that bad but it definitely wasn't my best performance, missed out on a couple more A Main Podiums due to breaking......Next up Micro Touring Nationals.....Looking for a National Title repeat and much more.........

Wesley
Micro-Man is offline  
Old 04-10-2008, 05:11 AM
  #1364  
wyd
Tech Legend
iTrader: (51)
 
wyd's Avatar
 
Join Date: Sep 2001
Location: Castle Mamba Max Pro. Feel its power!!!!!!!!!!
Posts: 21,220
Trader Rating: 51 (100%+)
Default

Originally Posted by Micro-Man
I didn't do all that bad but it definitely wasn't my best performance, missed out on a couple more A Main Podiums due to breaking......Next up Micro Touring Nationals.....Looking for a National Title repeat and much more.........

Wesley
Hey sometimes breaking happens while non of us like it. The thing is you made the shows.
wyd is offline  
Old 04-10-2008, 07:25 AM
  #1365  
Tech Regular
Thread Starter
 
Joe Ford's Avatar
 
Join Date: Nov 2006
Location: Olathe, KS
Posts: 287
Default

All of our guys did really well at the event and I can't wait to see what they can do at the Onroads...it showed just how well they represented us when I got home to find emails from people with nothing but kind words to say about all our drivers...their demeanor, professionalism, and willingness to help anyone that needed it. Great job to all you guys!
Joe Ford is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.