R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road > Team and Company Discussions

Like Tree3Likes
Reply
 
Thread Tools Search this Thread
Old 11-21-2007, 01:32 PM   #976
Tech Regular
 
barber's Avatar
 
Join Date: Feb 2007
Location: babados
Posts: 269
Trader Rating: 4 (100%+)
Default

Quote:
Originally Posted by Joe Ford View Post
No, there's a separate board for the Castle Link that plugs into the receiver plug on the Mamba 25...you'd need it to plug the Mamba 25 in. It doesn't come with the Max.
ygpm joe
__________________
BARBER SHOP RACING.
Hara Cyclone Edition,MAMBA 7700KV,Spectrum,
Mazdaspeed 6 Painted By McGoo Creations,
JR Z1,Orion 4300Mah,Ib 4200Mah,Ice,Rp,Trinity.
Race Prepaired & Driven By TEAM DRIVER (BARBER)
barber is offline   Reply With Quote
Old 11-21-2007, 04:32 PM   #977
Tech Adept
 
Join Date: Jul 2006
Posts: 166
Default

well, lets say then i dont have posibility for USB programing and i dont want to buy more stuff...

i did some tests today , when i connect the battery, the mamba 25 makes 1 ring, waits a little and then 2 rings in a row, then it shows a RED solid light , no yellow

i make the calibration , all looks right, at the end , finish with the 4 rings for the neutral position calibrated, wait 1 second and 2 rings more to say its armed, then RED solid light again

i push the gun and red light start flashing but no motor movement, i push brake and red light flashing but no motor movement, when i leave the gun alone in neutral position , it shows red solid , should it be yellow? i dont really remember what light was for neutral when the ESC was workign right.

i also checkd the transmiter for not zero trim on throtle , it was indeed not in zero , but i changed to zero and repeat calibration... same thing , the motor is like dead ....

please HELP!
DrKucho is offline   Reply With Quote
Old 11-21-2007, 06:53 PM   #978
Tech Adept
 
Nitrobuggies's Avatar
 
Join Date: Nov 2006
Location: Campbelltown, Sydney
Posts: 234
Default

Hey guys.

I got a Mamba 25 Speed Controller here. It is connected to a Trinity Mini Cobalt Brushless and does not seem to work.

The Servo works fine, and everything. But when i try to accelerate or use reverse nothing happens. I have followed to instructions in the manual, and done step 3.1 i believe it is many times, and done it exactly to how the manual says. After setting the speed controller i still get no motion from the motor. I connected a brand new Dynamite C4 8000kv to it and same thing. So i checked both motors on another cheaper speed controller and it worked instantly.

What could it be???

Also could someone please tell me what wire does what on the Trinity motor. Which one is Positive, Negative and earth. I believe the Red is Positive, Green is earth and Yellow is Negative. Is this correct????
Nitrobuggies is offline   Reply With Quote
Old 11-22-2007, 12:02 AM   #979
Tech Adept
 
Super_Roo's Avatar
 
Join Date: Jan 2007
Posts: 143
Trader Rating: 1 (100%+)
Default

DrKucho - Try reversing the throttle channel on your radio and then recalibrate and see if that works. Also if your radio has a 70/30 switch for the throttle trigger switch, make sure its set to 50/50 and if not recalibrate.
Super_Roo is offline   Reply With Quote
Old 11-22-2007, 03:27 AM   #980
Tech Adept
 
Join Date: Jul 2006
Posts: 166
Default

Quote:
Originally Posted by Nitrobuggies View Post
Hey guys.

I got a Mamba 25 Speed Controller here. It is connected to a Trinity Mini Cobalt Brushless and does not seem to work.

The Servo works fine, and everything. But when i try to accelerate or use reverse nothing happens. I have followed to instructions in the manual, and done step 3.1 i believe it is many times, and done it exactly to how the manual says. After setting the speed controller i still get no motion from the motor. I connected a brand new Dynamite C4 8000kv to it and same thing. So i checked both motors on another cheaper speed controller and it worked instantly.

What could it be???

Also could someone please tell me what wire does what on the Trinity motor. Which one is Positive, Negative and earth. I believe the Red is Positive, Green is earth and Yellow is Negative. Is this correct????
you may have same problem than me, please describe how lights do when you throtle, reverse and stay in neutral

about the cables in any BL motor , what i know is : it doesnt matter which one is which one, just connect them to any cable coming from the ESC and if the motor spins reversed, just swap two cables and it will work fine , that's all you have to know ...i belive
DrKucho is offline   Reply With Quote
Old 11-22-2007, 03:40 AM   #981
Tech Adept
 
Join Date: Jul 2006
Posts: 166
Default

Quote:
Originally Posted by Super_Roo View Post
DrKucho - Try reversing the throttle channel on your radio and then recalibrate and see if that works. Also if your radio has a 70/30 switch for the throttle trigger switch, make sure its set to 50/50 and if not recalibrate.
thanks i will check the reverse thing , but it shouldnt be the reason as it was working before ....

my radio is 50/50
DrKucho is offline   Reply With Quote
Old 11-22-2007, 03:08 PM   #982
Tech Adept
 
Join Date: Jul 2006
Posts: 166
Default

did the reverse test but didnt work , i also ccconected the mamba 25 to a diferent car with diferent receiver and controlled by a diferent transmiter, the thing wss doing the same , calibrated for new transmiter but problem still there

im doing all these things but i dont really see the point of the problem in the transmiter settings, it makes no sense, because the calibration is exactly for that , to adapt to your radio . so if the problem is a wrong setting in the transmitter, calibration should fix it , but it is not ....

help .... help , HELP !
DrKucho is offline   Reply With Quote
Old 11-22-2007, 09:24 PM   #983
Tech Fanatic
 
Mooshu Beef's Avatar
 
Join Date: Jul 2007
Location: State of Insanity
Posts: 790
Trader Rating: 7 (100%+)
Default

Hey Joe, will the sidewinder have a brushed profile as well? Or will it solely be a brushless system?

I have a GTX that I am going to sell, and another ESC that I can get a good deal on, but I don't want to buy it if I can get the Sidewinder ESC for $80...

Aahh... brushless conversion is so tempting.
__________________
I am a man of few words.
Mooshu Beef is offline   Reply With Quote
Old 11-23-2007, 01:22 PM   #984
Tech Adept
 
Join Date: Jul 2006
Posts: 166
Default

i found what was wrong.... my battery was discharged !!!!!

i think the red light instead the yellow one is saying that the lipo cutoff is not allowing you to thortle, if this is correct , it would be a good idea to include this in the manual

as well as correct the mistakes on the programing guide steps , cause it says rings in two steps but it should say beep, and some other wrong steps order in the calibrating secuence ...

sorry about my stupidity , i should check the battery before but it should not be discharged thats why i didnt think about this

still not 100% sure the problem is gone cause battery is still charging , but i think this is it
DrKucho is offline   Reply With Quote
Old 11-25-2007, 05:29 PM   #985
Tech Fanatic
 
Join Date: Jun 2007
Location: Adrian, MI
Posts: 823
Trader Rating: 1 (100%+)
Default

Well I thought about your dead battery thing today when my car was not working right When I hit the throttle my car would slow down and I tried everything to fix it Then after like 45min. I put my other LIPO in and low and behold the car was just fine I must of hit the discharge instead of charge and well !!! it said it was done!!!! so I put it in my car.!!! Now I know what happens when the LIPO cut off works like its suposed to, I set mine at 6.5 so no harm done. I just thought I would share that with you .......Mamba max rules......... even when you make mistake's.
Lazer Guy is offline   Reply With Quote
Old 11-26-2007, 08:33 AM   #986
Tech Fanatic
 
Join Date: May 2006
Location: cincinnati ohio
Posts: 881
Trader Rating: 93 (100%+)
Default Cooling fan

Hi I'm running a mamba max 7700 In a dirt oval car and when i gear it hard the speed control gets hot from no air getting to it. I checked it after a run and it was 290 degrees! Can someone give me an idea where to buy a cooling fan to put on it? I have seen them before but can't find one now. Thanks
latemodel13 is offline   Reply With Quote
Old 11-26-2007, 07:15 PM   #987
Tech Regular
 
barber's Avatar
 
Join Date: Feb 2007
Location: babados
Posts: 269
Trader Rating: 4 (100%+)
Default

Quote:
Originally Posted by latemodel13 View Post
Hi I'm running a mamba max 7700 In a dirt oval car and when i gear it hard the speed control gets hot from no air getting to it. I checked it after a run and it was 290 degrees! Can someone give me an idea where to buy a cooling fan to put on it? I have seen them before but can't find one now. Thanks
nexus racing look under brushless motor acc i am using the intergy one.
__________________
BARBER SHOP RACING.
Hara Cyclone Edition,MAMBA 7700KV,Spectrum,
Mazdaspeed 6 Painted By McGoo Creations,
JR Z1,Orion 4300Mah,Ib 4200Mah,Ice,Rp,Trinity.
Race Prepaired & Driven By TEAM DRIVER (BARBER)
barber is offline   Reply With Quote
Old 11-26-2007, 07:54 PM   #988
Tech Regular
 
Joe Ford's Avatar
 
Join Date: Nov 2006
Location: Olathe, KS
Posts: 287
Send a message via AIM to Joe Ford
Default

Quote:
Originally Posted by latemodel13 View Post
Hi I'm running a mamba max 7700 In a dirt oval car and when i gear it hard the speed control gets hot from no air getting to it. I checked it after a run and it was 290 degrees! Can someone give me an idea where to buy a cooling fan to put on it? I have seen them before but can't find one now. Thanks
I've seen my MM's at 275F+ quite often...as long as the motor stays below 200F and your ESC isn't thermaling you don't HAVE to use a fan. If you'd like to though, it won't hurt anything.

Quote:
Originally Posted by Mooshu Beef View Post
Hey Joe, will the sidewinder have a brushed profile as well? Or will it solely be a brushless system?

I have a GTX that I am going to sell, and another ESC that I can get a good deal on, but I don't want to buy it if I can get the Sidewinder ESC for $80...

Aahh... brushless conversion is so tempting.
Yes, it will be brushed and brushless.
__________________
Joe Ford
Product Specialist
Castle Creations
Joe Ford is offline   Reply With Quote
Old 11-27-2007, 09:26 AM   #989
Tech Addict
 
Island Losi's Avatar
 
Join Date: Apr 2007
Location: Barbados
Posts: 473
Trader Rating: 3 (100%+)
Default

Quote:
Originally Posted by Joe Ford View Post
I've seen my MM's at 275F+ quite often...as long as the motor stays below 200F and your ESC isn't thermaling you don't HAVE to use a fan. If you'd like to though, it won't hurt anything.



Yes, it will be brushed and brushless.


Damn i guess the esc is 'Built Ford Tough'
__________________
Yokomo|SpeedPassion|McgooCreative|TeamOrion|FusionPower|Futaba|Spektrum|RP|Trinity|Protoform
Island Losi is offline   Reply With Quote
Old 11-27-2007, 09:28 AM   #990
Tech Regular
 
barber's Avatar
 
Join Date: Feb 2007
Location: babados
Posts: 269
Trader Rating: 4 (100%+)
Default

Quote:
Originally Posted by Island Losi View Post
Damn i guess the esc is 'Built Ford Tough'
it would not last long at those temps.
__________________
BARBER SHOP RACING.
Hara Cyclone Edition,MAMBA 7700KV,Spectrum,
Mazdaspeed 6 Painted By McGoo Creations,
JR Z1,Orion 4300Mah,Ib 4200Mah,Ice,Rp,Trinity.
Race Prepaired & Driven By TEAM DRIVER (BARBER)
barber is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Castle Creations Appreciation Thread TeckLancer Electric On-Road 2 08-12-2008 03:16 AM
FS: Castle Creations Sidewinder with Mamba 5700 Brushless setup with Castle Link salteen R/C Items: For Sale/Trade 0 06-24-2008 06:51 AM
castle creations Mamba BL ESC and Trinity cobalt "B" BL motor , castle link USB vintagetamiya R/C Items: For Sale/Trade 3 01-14-2008 05:25 PM
Castle Creations Mamba Max paul73rc Australia Wanted to Buy 6 01-04-2008 03:41 PM
FS: Castle Creations Mamba Max ESC Mustangz R/C Items: For Sale/Trade 4 12-16-2007 07:52 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 10:30 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net