R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road > Team and Company Discussions

Like Tree3Likes
Reply
 
Thread Tools Search this Thread
Old 07-20-2009, 11:08 PM   #2041
Tech Adept
 
Join Date: Jun 2009
Location: Los Angeles
Posts: 172
Trader Rating: 5 (100%+)
Default Circuit board seperating from half-shell case!

I just ran my new, recently purchased MM/5700 in a Slash today and at the end of the third run I saw the board inches away from its case which was still velcroed to the chassis. One mini cap head screw is missing and the case screw holes appeared widened or stripped. A good reason other ESCs use full cases.

------------------------------------------------------------------------------------------------------------------------------------------------------------------
CC Support sent me a new shell and screws; received the package 08-10-2009.

Last edited by Tired Racer; 08-15-2009 at 09:44 PM. Reason: *UPDATE*
Tired Racer is offline   Reply With Quote
Old 07-21-2009, 02:03 AM   #2042
Tech Master
 
drperry's Avatar
 
Join Date: Dec 2008
Location: Grande Prairie, AB
Posts: 1,222
Trader Rating: 3 (100%+)
Send a message via AIM to drperry Send a message via MSN to drperry Send a message via Yahoo to drperry
Default

Must be something in the new batch of cases...

I've got the first release, and it's still solid as a rock.
__________________
RC18MT - Tekin FX/Stock motor
Yokomo MR-4TC SD CM Novak GTB/LRP X-11 13.5 brushless
E-Jato - Diff still unloads in corners, with 100k weight oil in it!
drperry is offline   Reply With Quote
Old 07-27-2009, 07:09 PM   #2043
Tech Fanatic
 
jmcvicker's Avatar
 
Join Date: Jan 2008
Location: SE Pennsylvania
Posts: 814
Trader Rating: 2 (100%+)
Default

First run/race with 2650 setup in an OFNA 9.5 - yeah, I agree with 2650 being a hot motor (can't want to see the 1900 available).

I really enjoyed running last Saturday with my first "real" RC car - a converted OFNA 9.5 pro with the MMM+2650. However, I do have a bit of ESC programming to do to clean up the powerband. Quite a bit easier to drive than 2WD 10th scales.

Geared 13/46 - I ran it with one 30C 3S1P 5000 mAh battery and was easily able to keep up with the Nitros (Qual 2nd out of 6 in a basically Intermediate class). Best lap time was with Throttle EPA turned way down to 95 in first heat but then average lap times dropped going up to 110 and 115 for next heats. After 5-min heats, battery was about 120F and motor 140F.

Ran about 10 minutes into the main and had the battery down below 20% capacity and it was pretty darn warm (135*F). So, I learned that the motor is wanting more Amps and keep the LiPo(s) from going-low.

I'm going to setup as a 3S2P with two packs instead to allow 1/2 amp draw on each battery. I'm also looking to run a 12T/46 gearing. I figure a bit less amp draw on acceleration with lower gear ratio along with double-batteries should easily give 20-25 minute races.

But my question is:

Since CC says "ESC and motor work harder when switching below Full Throttle" - should I be trying to keep the motor spinning at or near top-end with lower-gearing or look to keep off the throttle with a higher gear ratio and just kind of drive in shorter bursts - and then have "thrilling" top-speed on tracks' main straights? Just wondering if the motor is drawing higher amps when spinning than when accelerating. I guess harder starting-torque causes more amp-draw (which is typical for any electric motor) - so I'm leaning on keeping gearing low.
jmcvicker is offline   Reply With Quote
Old 07-31-2009, 08:55 PM   #2044
Tech Master
 
rregl0612's Avatar
 
Join Date: Jul 2006
Location: harrisburg, Pa
Posts: 1,011
Trader Rating: 33 (100%+)
Default

Castle, are there any plans or have there been any changes to make the mamba max accept input from windows vista 64.
I love my mamba but will be running electric this winter full time and if I cant adjust my settings without cog it is pretty much useless!
Thanks for any help
__________________
Thanks to my sponsors, My Wallet, endorsed by Some crazy pharmaceutical corporation!!!
Member of "The White Wheel Mafia!"
Bumps and Jumps, Pitstop Hobbies, LCRC!
rregl0612 is offline   Reply With Quote
Old 08-01-2009, 04:10 AM   #2045
Tech Master
 
drperry's Avatar
 
Join Date: Dec 2008
Location: Grande Prairie, AB
Posts: 1,222
Trader Rating: 3 (100%+)
Send a message via AIM to drperry Send a message via MSN to drperry Send a message via Yahoo to drperry
Default

Quote:
Originally Posted by rregl0612 View Post
Castle, are there any plans or have there been any changes to make the mamba max accept input from windows vista 64.
I love my mamba but will be running electric this winter full time and if I cant adjust my settings without cog it is pretty much useless!
Thanks for any help

You have to download the driver for the communications chip in the ESC... From the people who made the chip. I forget who/where to get it from, though.

Unless things have changed, Castle has no intentions of having 64-bit support for the Mamba Max.
__________________
RC18MT - Tekin FX/Stock motor
Yokomo MR-4TC SD CM Novak GTB/LRP X-11 13.5 brushless
E-Jato - Diff still unloads in corners, with 100k weight oil in it!
drperry is offline   Reply With Quote
Old 08-01-2009, 04:41 PM   #2046
wyd
Tech Legend
 
wyd's Avatar
 
Join Date: Sep 2001
Location: Castle Mamba Max Pro. Feel its power!!!!!!!!!!
Posts: 21,141
Trader Rating: 50 (100%+)
Send a message via AIM to wyd
Default

Quote:
Originally Posted by rregl0612 View Post
Castle, are there any plans or have there been any changes to make the mamba max accept input from windows vista 64.
I love my mamba but will be running electric this winter full time and if I cant adjust my settings without cog it is pretty much useless!
Thanks for any help
Chris at Bumps has the Castle Link to adjust your speedo plus me, Chad, Aaron, and Scotty all have computers with the Castle Link setup at the track. One of us is their pretty much every week. Once you the the most updated software you should have cogging issues. I didn't have any cogging problems for the last 2 years with the MM or Sidewinder. Only time I did is when the bullets on the motor where worn out out.
__________________
Castle Creations (Since 2005) Just awesome products
Bumps & Jumps RC (Great Indoor facility for offroad and oval)
ST Racing Concepts (STRC)
Custom Works (Best Oval Cars around)
wyd is offline   Reply With Quote
Old 08-02-2009, 01:28 AM   #2047
Tech Master
 
drperry's Avatar
 
Join Date: Dec 2008
Location: Grande Prairie, AB
Posts: 1,222
Trader Rating: 3 (100%+)
Send a message via AIM to drperry Send a message via MSN to drperry Send a message via Yahoo to drperry
Default

Quote:
Originally Posted by wyd View Post
Chris at Bumps has the Castle Link to adjust your speedo plus me, Chad, Aaron, and Scotty all have computers with the Castle Link setup at the track. One of us is their pretty much every week. Once you the the most updated software you should have cogging issues. I didn't have any cogging problems for the last 2 years with the MM or Sidewinder. Only time I did is when the bullets on the motor where worn out out.
Too bad there's no CC released 64 bit solution for the Mamba Max, though

Maybe I need to change my bullets on mine... My Clod cogs on me, with the latest firmware... But, they're also first release units...

Which, btw, are most likely going to die this month at Drag Wars!

Someone is going to let me attatch a Mamba Monster Max to my 5700... And it's going to grenade the motor, as it's going to be 6s, lol.
__________________
RC18MT - Tekin FX/Stock motor
Yokomo MR-4TC SD CM Novak GTB/LRP X-11 13.5 brushless
E-Jato - Diff still unloads in corners, with 100k weight oil in it!
drperry is offline   Reply With Quote
Old 08-02-2009, 09:18 PM   #2048
Tech Addict
 
ovalosi's Avatar
 
Join Date: Feb 2009
Location: tn
Posts: 637
Trader Rating: 55 (100%+)
Default ?

I AM ABOUT TO CONVERT MY BUGGY TO ELECTRIC USING THE MAMBA MONSTER AND I AM UNSURE OF WHICH MOTOR TO PURCHASE. I PLAN ON RUNNING MOSTLY 4S BUT WANT TO BE ABLE TO USE 5S ALSO. COULD SOMEONE RECOMMEND WHICH MOTOR I SHOULD GET AND ALSO GIVEME AN IDEA OF WHAT GEARING I WOULD NEED FOR THE LOSI 8B. ALSO IF YOU RUN 2 2S BATTERIES DO THEY HAVE TO BE THE SAME CAPACITY. AND ALSO CAN YOU RUN A 2S AND A 3S TOGETHER FOR 5S. SORRY IF I SOUND LIKE A ROOKIE, I AM NO ROOKIE I HAVE JUST BEEN RUNNIG NITRO FOR A WHILE.THE LAST TIME I RAN ELECTRIC THE BATTERIES OF CHOICE WERE 1400SCR.
ovalosi is offline   Reply With Quote
Old 08-03-2009, 11:31 PM   #2049
Tech Addict
 
Xtant3150c's Avatar
 
Join Date: Dec 2002
Location: Kaneohe, HI
Posts: 681
Trader Rating: 10 (100%+)
Default

I would like to know if the 1/10th Scale Sidewinder ESC would be able to run 2 Tamiya Johnson 540 motors in a Clod Buster on 2S LiPo power?

ThanX
__________________
space for rent
Xtant3150c is offline   Reply With Quote
Old 08-04-2009, 09:44 AM   #2050
Tech Initiate
 
Join Date: Jul 2009
Posts: 25
Default

Just sent my MM 4600kv combo back to CC for warranty. It was installed in my newly built Factory Team B4 w/ 18/87 gearing, a 6c 4500mah Nimh, Deans connector. Calibrated to my radio no problem. Operated properly for about 3 laps of my paved drive and nearly came to a stop while cogging. Could smell burning when I approached. Positive wire near circuitboard was hot and circuit board was glowing red and smoking near positive connector. Hit the power switch quickly. I'm sure it was about to burst into flames. I'm bummin'. Anyone have any idea what the warranty wait is these days?
galland1 is offline   Reply With Quote
Old 08-04-2009, 02:26 PM   #2051
Tech Elite
 
Join Date: Jun 2009
Posts: 4,082
Trader Rating: 32 (100%+)
Default

I have a mamba max esc/7700kv system. the battery setting was set to "Auto/Lipo". I am using ni/mh. the truck was sputtering and sometimes not responding. i changed the setting to 5v cut off. is this ok? it seems to be working now, but i didnt get to run it, only test its responsiveness. as mentioned, it seems to be ok. not sure if this would have been the problem or if i should just send the system in for servicing.

any words of wisdom would be greatly appreciated.
marooko is offline   Reply With Quote
Old 08-04-2009, 03:15 PM   #2052
Tech Elite
 
Join Date: Jun 2009
Posts: 4,082
Trader Rating: 32 (100%+)
Default

Quote:
Originally Posted by galland1 View Post
Just sent my MM 4600kv combo back to CC for warranty. It was installed in my newly built Factory Team B4 w/ 18/87 gearing, a 6c 4500mah Nimh, Deans connector. Calibrated to my radio no problem. Operated properly for about 3 laps of my paved drive and nearly came to a stop while cogging. Could smell burning when I approached. Positive wire near circuitboard was hot and circuit board was glowing red and smoking near positive connector. Hit the power switch quickly. I'm sure it was about to burst into flames. I'm bummin'. Anyone have any idea what the warranty wait is these days?
I just got mine back yesterday. I had emailed and was told 2-3 weeks. I got it back just short of 3 weeks. But that's including shipping both ways. I think I sent it out on a Tuesday, 3 weeks ago, and got it yesterday. As promised.

And yeah, I feel for ya. I almost went out and bought a new set-up so i wouldn't have to wait. hahaha.
marooko is offline   Reply With Quote
Old 08-05-2009, 02:53 PM   #2053
Tech Addict
 
Join Date: Aug 2002
Posts: 602
Trader Rating: 1 (100%+)
Default conversion

just converted my mugen mbx5r to the castle conversion and picked up a mm
2650 systems , what i need to know is battery requirment needed . thks 4 your support
isuzuguy is offline   Reply With Quote
Old 08-05-2009, 05:31 PM   #2054
Tech Master
 
Join Date: Jul 2009
Posts: 1,039
Trader Rating: 4 (83%+)
Default

Can I run a Castle Creations Sidewinder combo 4600 with esc in my Yokomo MR4TC SD CMS safely?
DriftWoof is offline   Reply With Quote
Old 08-05-2009, 06:37 PM   #2055
Tech Master
 
drperry's Avatar
 
Join Date: Dec 2008
Location: Grande Prairie, AB
Posts: 1,222
Trader Rating: 3 (100%+)
Send a message via AIM to drperry Send a message via MSN to drperry Send a message via Yahoo to drperry
Default

Quote:
Originally Posted by DriftWoof View Post
Can I run a Castle Creations Sidewinder combo 4600 with esc in my Yokomo MR4TC SD CMS safely?
As long as you don't over or under gear.
__________________
RC18MT - Tekin FX/Stock motor
Yokomo MR-4TC SD CM Novak GTB/LRP X-11 13.5 brushless
E-Jato - Diff still unloads in corners, with 100k weight oil in it!
drperry is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Castle Creations Appreciation Thread TeckLancer Electric On-Road 2 08-12-2008 03:16 AM
FS: Castle Creations Sidewinder with Mamba 5700 Brushless setup with Castle Link salteen R/C Items: For Sale/Trade 0 06-24-2008 06:51 AM
castle creations Mamba BL ESC and Trinity cobalt "B" BL motor , castle link USB vintagetamiya R/C Items: For Sale/Trade 3 01-14-2008 05:25 PM
Castle Creations Mamba Max paul73rc Australia Wanted to Buy 6 01-04-2008 03:41 PM
FS: Castle Creations Mamba Max ESC Mustangz R/C Items: For Sale/Trade 4 12-16-2007 07:52 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 04:50 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net