R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road > Team and Company Discussions

Like Tree3Likes
Reply
 
Thread Tools Search this Thread
Old 10-02-2008, 01:01 AM   #1666
Tech Elite
 
Join Date: Sep 2001
Posts: 3,117
Trader Rating: 69 (100%+)
Default

if you have clearance under the body, try mounting the esc at an angle, similar to what you can do on the TC4 touring car with the cooling fan wedge make a wedge out of scrap lexan and mount the esc on that
marvi is offline   Reply With Quote
Old 10-02-2008, 06:48 AM   #1667
Tech Fanatic
 
Join Date: Jun 2007
Location: Adrian, MI
Posts: 823
Trader Rating: 1 (100%+)
Default

I think it would be great if Castle would move the USB to the end instead of the side.
Lazer Guy is offline   Reply With Quote
Old 10-02-2008, 02:42 PM   #1668
Registered User
 
UltegraSTI's Avatar
 
Join Date: Jul 2005
Posts: 7,171
Trader Rating: 20 (100%+)
Default

i had my b4 notched, race all year, no probs. plug right in the side of the car, even with body lifted if i was doin it on the quick. no worries at all.

sidenote: mike G is prolly missing on a potential business in modifying mamba25/sidewinder micros. if you've ever tried to mount 1 on an exotek r3, u'll understand what i mean. w00t!

R
UltegraSTI is offline   Reply With Quote
Old 10-02-2008, 03:11 PM   #1669
Tech Regular
 
Joe Ford's Avatar
 
Join Date: Nov 2006
Location: Olathe, KS
Posts: 287
Send a message via AIM to Joe Ford
Default

Quote:
Originally Posted by Lazer Guy View Post
I think it would be great if Castle would move the USB to the end instead of the side.
We're going to be removing it completely...causes too many hassles...#1 being mounting, #2 that none of our other products plug into the side and customers have to buy the Castle Link if they buy one of our other products. We're going back to the way it was...we thought it was a good idea at the time, but has caused nothing but problems.
__________________
Joe Ford
Product Specialist
Castle Creations
Joe Ford is offline   Reply With Quote
Old 10-02-2008, 03:16 PM   #1670
Registered User
 
UltegraSTI's Avatar
 
Join Date: Jul 2005
Posts: 7,171
Trader Rating: 20 (100%+)
Default

nonsense, it was a great idea. i say the only reason to remove it is to decrease the footprint. if you cant do that, then rubbish. i liked havin it there. so what if u need a link for other products. for over a yr i didnt have anythin but a max for the b4. i hadnt got into this micro crap yet (heh oh how things can change).

take all the complainers and those cryin for sensored roar legal crap and tell em to go turn on the cure and cry anyway, that or else u'll make em cry

muahahah

R
UltegraSTI is offline   Reply With Quote
Old 10-03-2008, 10:20 AM   #1671
Tech Rookie
 
Join Date: Oct 2008
Posts: 1
Default mamba 25 not reacting!

Hi everyone, After a long mamba mini-t layoff I decided to start my baby up. The problem is that I am not getting any response when I turn it on. It omitts the multiple chimes and the lights just flash. Have not touched any of the wires since its last use. Operated properly before then. Can anyone tell me what is causing this behavior and what shall i do to rectify this probem. Never reacted like this before. Thanks for any info you can provide.
eddie415 is offline   Reply With Quote
Old 10-04-2008, 08:11 AM   #1672
Tech Fanatic
 
Join Date: Jun 2007
Location: Adrian, MI
Posts: 823
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by Joe Ford View Post
We're going to be removing it completely......we thought it was a good idea at the time, but has caused nothing but problems.
WHAT?????? PLEASE don't do that !!!!! If I have to unplug my receiver wire every time I want to make a change that would cause me even more problems. One of the best things about the Mamba Max is the USB plug
I can make changes fast with it and thats what I need and like the most about the MM.
Lazer Guy is offline   Reply With Quote
Old 10-04-2008, 01:53 PM   #1673
Tech Master
 
chewiefttc4's Avatar
 
Join Date: Oct 2006
Location: algonac, mi
Posts: 1,552
Trader Rating: 26 (96%+)
Send a message via AIM to chewiefttc4 Send a message via Yahoo to chewiefttc4
Default

x2
chewiefttc4 is offline   Reply With Quote
Old 10-04-2008, 06:20 PM   #1674
Tech Adept
 
Join Date: Oct 2004
Posts: 180
Trader Rating: 1 (100%+)
Default

I would love to have the option of having a USB plug or be able to go through the receiver wire. In the B4/XXX cars I could use the receiver wire. On the B44 or my Losi 8 I could use the plug on the ESC. I plugged the receiver wire up on my MM and it engages the lights. I would love to have the option of either.
plumslow is offline   Reply With Quote
Old 10-04-2008, 06:23 PM   #1675
Tech Champion
 
geeunit1014's Avatar
 
Join Date: Sep 2005
Location: The dirty burnie
Posts: 5,505
Trader Rating: 12 (100%+)
Default

Quote:
Originally Posted by eddie415 View Post
Hi everyone, After a long mamba mini-t layoff I decided to start my baby up. The problem is that I am not getting any response when I turn it on. It omitts the multiple chimes and the lights just flash. Have not touched any of the wires since its last use. Operated properly before then. Can anyone tell me what is causing this behavior and what shall i do to rectify this probem. Never reacted like this before. Thanks for any info you can provide.
Reset your endpoints. that should most likely take care of it.
__________________
Mike Gee

Awesomatix USA/Pyscho Cells Racing/Tekin/Sweep Racing/RSD/180 Raceway/Johns Mobile Raceway/TQ Wire/Avid/Sanwa
geeunit1014 is offline   Reply With Quote
Old 10-04-2008, 06:51 PM   #1676
Tech Addict
 
Join Date: Oct 2005
Location: Northern NSW Australia
Posts: 734
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by marvi View Post
sorry if this was asked before but is 150 to 160 deg F a safe temp range for my mamba max? i ran several 7 minute offroad sessions with my durga. my orion vortex 4.5 was also in the 150-160 deg F range. should i use a cooling fan on both the esc & motor? the buggy ran fine, but i really dont know what temp range i should be looking at. thanks in advance for any info
it so happens that the other week at the gold coast running mod i checked the temp and the esc was 247 F and the 4600 was 180 a bit over geared but every thing is still working sweet.
Casino Kid is offline   Reply With Quote
Old 10-04-2008, 08:40 PM   #1677
wyd
Tech Legend
 
wyd's Avatar
 
Join Date: Sep 2001
Location: Castle Mamba Max Pro. Feel its power!!!!!!!!!!
Posts: 21,142
Trader Rating: 50 (100%+)
Send a message via AIM to wyd
Default

I wouldn't mind if they kept the USB port that it would run out of the top of the speedo because you can access it alot easier in most cars.
__________________
Castle Creations (Since 2005) Just awesome products
Bumps & Jumps RC (Great Indoor facility for offroad and oval)
ST Racing Concepts (STRC)
Custom Works (Best Oval Cars around)
wyd is offline   Reply With Quote
Old 10-05-2008, 10:42 AM   #1678
Tech Rookie
 
Join Date: Sep 2008
Posts: 6
Trader Rating: 2 (100%+)
Default

I recently put a Mamba Max/5700kv system in my XXXT-CR. Using a 17/82 combination and the motor gets too hot to touch after 10 minutes or so. I don't have a temp gauge so cant give an exact temp, but it feels way too hot to me.

Is it possible that a 17 tooth pinion is too small? Can running too small of a pinion cause the motor to get hot? I have a 20 tooth pinion also, but I've been afraid to even try that since the 17 already gets very hot.

I've put the timing to lowest already ,and the drivetrain and gear mesh is definitely not the problem.
grandaddy is offline   Reply With Quote
Old 10-05-2008, 02:15 PM   #1679
Tech Master
 
chewiefttc4's Avatar
 
Join Date: Oct 2006
Location: algonac, mi
Posts: 1,552
Trader Rating: 26 (96%+)
Send a message via AIM to chewiefttc4 Send a message via Yahoo to chewiefttc4
Default

go ahead and run that 20 tooth.

whats your motor timing at ? set it to normal or lowest put start power high though
chewiefttc4 is offline   Reply With Quote
Old 10-05-2008, 07:18 PM   #1680
Tech Rookie
 
Join Date: Sep 2008
Posts: 6
Trader Rating: 2 (100%+)
Default

Quote:
Originally Posted by chewiefttc4 View Post
go ahead and run that 20 tooth.

whats your motor timing at ? set it to normal or lowest put start power high though
Running on low at the moment. Why do you recommend high start power?

I've read that if you can't touch the motor for more than 2 seconds it is too hot, that's what has me worried about even trying the 20 tooth.
grandaddy is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Castle Creations Appreciation Thread TeckLancer Electric On-Road 2 08-12-2008 03:16 AM
FS: Castle Creations Sidewinder with Mamba 5700 Brushless setup with Castle Link salteen R/C Items: For Sale/Trade 0 06-24-2008 06:51 AM
castle creations Mamba BL ESC and Trinity cobalt "B" BL motor , castle link USB vintagetamiya R/C Items: For Sale/Trade 3 01-14-2008 05:25 PM
Castle Creations Mamba Max paul73rc Australia Wanted to Buy 6 01-04-2008 03:41 PM
FS: Castle Creations Mamba Max ESC Mustangz R/C Items: For Sale/Trade 4 12-16-2007 07:52 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 08:26 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net