Old 06-07-2004, 06:09 PM
  #16  
JayBee
Tech Champion
iTrader: (31)
 
JayBee's Avatar
 
Join Date: Mar 2004
Location: 12TH-MAN COUNTRY
Posts: 6,819
Trader Rating: 31 (100%+)
Post

Originally posted by Merciless
Something you guys may want to consider .......

I bought my VFS 2000j on the 20th april and left it in it's pretty box until last week when i installed it in my new 12th car ( crc Bloody Knife).

It ran prefect for the first 2 runs and then started to cut out on me. To the point i couldn't get it to go for the finial.

Post on the VFS thread for help and get told by "Ko Staff" i probably blow the fet's because i had only used the provided diode in the packaging and not another 4/6 needed for the 12 turn motor i was using ????????? (it mentioned this no were in the instructions)

I then get contacted by KO usa themselves (i presume KoStaff on the forums ?) they say i should contact helgar racing uk for a repairs for items not bought in the USA. I reply says i bought it from Speedtech they reply saying Still won't help as there is only a product defect warranty with there speed controls and its my fault for not using enough diodes ?? Also shipping would be expensive. Oh and best of all i should have done some "homework" on the speedo before use.... i suspose they mean trauling the internet for information they should have included in the manual but forgot so as to stop me blowing it ??

DAMN MAN-- THAT SUCKS!!; have you tried talking to Steve @ Speedtech?
I don't know if he can do for you, but go ahead & give him a try.
SORRY MAN -- I know you shelled out a handful for that KO. If you can't get it remedied, what are you going to replace it with (possibly the Keyence )
JayBee is offline