View Single Post
Old 02-09-2003, 06:52 PM   #1
warlord385
Tech Adept
 
warlord385's Avatar
 
Join Date: May 2002
Posts: 237
Default Power supply problem

I used my LRP pulsar competition charger last night on the PYramid power supply and it worked fine. When i went to the track today The pulsar charger said "CHARGE INTERRUPTED CURRENT TOO HIGH) Every few seconds this message would come up. I cut everything off and tried and tried again. Eventually the last time i hooked the charger to the power supply the charger said imput to high. i checked the output with a voltmeter and it was reading 26.6 Volts. I tried to check amps but then the power supply's red protection light came on and cut off after i remove teh multimeter. I checked the voltage again and it was now reading 11Volts. I then tried to hook the charger to the power supply but now the red protection light comes on whenever i hooked it up. I went to radio shack and paid 90 bucks for a radioshack 10amp constant power supply and now everthing works fine. Any advice on what went wrong and how to fix it so i can get my 90 bucks back in 30 days. Thanks
warlord385 is offline   Reply With Quote