Go Back  R/C Tech Forums > General Forums > Rookie Zone
sc 10 brushless rs >

sc 10 brushless rs

sc 10 brushless rs

Reply

Old 03-05-2012, 10:53 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Mar 2012
Posts: 3
Default sc 10 brushless rs

I am new to the rc race world and need some help, i have 2 trucks; sc10 pro comp and sc10 monster. they drive differently from each other, sound differently, its like they are 2 completly different trucks but everything is suppose to be the exact same, is there anything i am missing to why they seem so different? could it be the gear ratio or something, idk like i said I am new to all this. if you reply plz. use words ill be able to understand considering im a girl and dont know much about them yet i just like to go out to the track and race, and kick butt! thanks for all the help in advanc
amiej18 is offline  
Reply With Quote
Old 03-06-2012, 01:20 AM
  #2  
Tech Initiate
 
Join Date: Feb 2012
Location: Longwood, FL
Posts: 35
Default

On a quick comparison, assuming they are both 2wd, the biggest difference I found was the speed control is the SC450 on the pro comp, and the SC700 on the monster. The SC700 probably allows more advanced settings like timing, which may have an effect on the performance.
cam94z28 is offline  
Reply With Quote
Old 03-06-2012, 11:30 AM
  #3  
Tech Master
 
rcduder's Avatar
 
Join Date: Oct 2011
Location: Tacoma, WA
Posts: 1,124
Default

Originally Posted by amiej18 View Post
I am new to the rc race world and need some help, i have 2 trucks; sc10 pro comp and sc10 monster. they drive differently from each other, sound differently, its like they are 2 completly different trucks but everything is suppose to be the exact same, is there anything i am missing to why they seem so different? could it be the gear ratio or something, idk like i said I am new to all this. if you reply plz. use words ill be able to understand considering im a girl and dont know much about them yet i just like to go out to the track and race, and kick butt! thanks for all the help in advanc
maybe check the slipper clutch and differential(take the left axle off by where the motor is sitting and there should be a crew in the middle that can be adjusted or on the other side possibly idk how associated assembles them or on what side and check the screws that attach the motor plate to the transmission there on the left side of the transmission easily accessible there are three of them with spacers under them. they sometimes come loose because its metal on metal and i also need to check mine after every race just to make sure. and it shouldn't be gear ratio as they all come the same from the factory unless you have change the pinion gear or the slipper gear.

hope this helps!
rcduder is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service