Go Back  R/C Tech Forums > General Forums > Rookie Zone
charging problem!! >

charging problem!!

charging problem!!

Old 12-04-2011, 02:20 AM
  #1  
Tech Adept
Thread Starter
 
Join Date: Jul 2011
Location: bendigo VIC, AU
Posts: 186
Default charging problem!!

i have a venom pro charger and am trying to chargemy glow plug!!
can someone please tell me what i need to do to get it charging??
its 1.2v and 1300mah..... please help
losi8isgr8! is offline  
Old 12-04-2011, 11:37 AM
  #2  
Tech Master
iTrader: (7)
 
Join Date: Jun 2011
Location: Illinois
Posts: 1,595
Trader Rating: 7 (100%+)
Default

Originally Posted by losi8isgr8!
i have a venom pro charger and am trying to chargemy glow plug!!
can someone please tell me what i need to do to get it charging??
its 1.2v and 1300mah..... please help
Do you have this part here to use http://www3.towerhobbies.com/cgi-bin...?&I=LXSGN7&P=7 you will need this to charge it from the charger you have i think it the one thing it dont come with brand new.
imrob is offline  
Old 12-04-2011, 09:55 PM
  #3  
Tech Adept
Thread Starter
 
Join Date: Jul 2011
Location: bendigo VIC, AU
Posts: 186
Default

its all good now mate, got it sussed out
losi8isgr8! is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.