Go Back  R/C Tech Forums > General Forums > Rookie Zone
Help diagnosing a issue. >

Help diagnosing a issue.

Like Tree1Likes
  • 1 Post By Bud

Help diagnosing a issue.

Old 06-22-2020, 06:35 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Jun 2020
Posts: 3
Default Help diagnosing a issue.

I have an Ecx Torment, and when I was running it I hit a curb. Now the car has little power on the ground. When the car is on the ground it moves slow while the motor is at full speed. I wanna say it is the slipper clutch, but the drivetrain spins too. I dunno what it is.
narkosa2512 is offline  
Old 06-23-2020, 08:40 AM
  #2  
Tech Adept
iTrader: (18)
 
Biz73's Avatar
 
Join Date: Mar 2018
Posts: 145
Trader Rating: 18 (100%+)
Default

Check to make sure the grub screw in you pinion gear is tight. If it gets loose the pinion can spin on the motor shaft rather than spinning with it.
Biz73 is offline  
Old 06-26-2020, 12:49 PM
  #3  
Tech Addict
iTrader: (26)
 
GerryH's Avatar
 
Join Date: Nov 2009
Posts: 525
Trader Rating: 26 (100%+)
Default

Check your gear mesh. Pretty common problem on the ECX trucks as the motor screws don't hold well. You crash into something and the motor shifts forward. A telltale sign is a terrible noise from the motor.

Another thing to check is to make sure your driveshafts are still in one piece. The Torments have pretty weak driveshafts.
GerryH is offline  
Old 06-26-2020, 02:09 PM
  #4  
Tech Elite
 
the rc guy's Avatar
 
Join Date: Aug 2016
Location: Detroit
Posts: 2,404
Default

check axels pins inside the wheel hex ..gotta pull wheels off ..
the rc guy is offline  
Old 06-28-2020, 08:53 AM
  #5  
Tech Rookie
Thread Starter
 
Join Date: Jun 2020
Posts: 3
Default Fixed!

Thanks for all the ideas. I checked it all. Wheel hexes were still in great condition, and the driveshafts too. It is funny though I took the cover off to check the mesh it was fine as well. Then I took it out to see if I could see the problem when it was running. Then it jumps back to life runs perfectly fine. I dunno if taking the cover off loosened it up or what. I place the cover on and it works fine.
narkosa2512 is offline  
Old 06-29-2020, 11:51 AM
  #6  
Bud
Tech Addict
 
Join Date: Mar 2004
Posts: 528
Default

Problems that fix themselves make me nervous. Don't know what happened and don't know when it'll happen again.
IndyRC_Racer likes this.
Bud is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.