Go Back  R/C Tech Forums > General Forums > RC Flight
Problem calibrating my quadcopter. Please help!! :( >

Problem calibrating my quadcopter. Please help!! :(

Problem calibrating my quadcopter. Please help!! :(

Reply

Old 05-19-2013, 09:10 AM
  #1  
Tech Rookie
Thread Starter
 
Join Date: May 2013
Posts: 3
Default Problem calibrating my quadcopter. Please help!! :(

Hi all, i just got my quadcopter from h t t p : // shop.rotor.com.sg/show-detail.asp?prodid={77AA67C2-D879-40F8-B8B9-F5E4110DF887}&pn=1#.UZj2WkrTT7E

I have problem calibrating the yaw,pitch and roll therefore, whenever i try to take off, the whole thing will just flip.

Here is the manual:
h t t p s : / / docs.google.com/file/d/0B_JCA3Yx_nFtQkxNdEpoR2R5V3M/edit?pli=1

Can someone help me to translate into a more understandable english?

Many thanks.
ex7rema is offline  
Reply With Quote
Old 05-22-2013, 05:00 PM
  #2  
Tech Master
iTrader: (31)
 
trickedout's Avatar
 
Join Date: Jun 2009
Location: Las Vegas/Pahrump,NV
Posts: 1,273
Trader Rating: 31 (100%+)
Default

Check over at r c groups. com much better multirotor support.
trickedout is offline  
Reply With Quote
Old 06-02-2013, 10:37 PM
  #3  
Suspended
 
Join Date: Mar 2013
Posts: 84
Default

Calibration is an ESC thing, and the procedure might be different from other ESCs. The flight controller only passes on the throttle signal (with some modifications) from the receiver to all ESCs at the same time.
I suggest you practice by connection one of them directly to the receiver (throttle channel), and follow the instructions for your ESC. When you find out how to do it, do them all together via the KK2.


Regards.
Andy.
Andy159 is offline  
Reply With Quote
Old 02-11-2018, 11:12 AM
  #4  
Tech Rookie
 
Join Date: Nov 2017
Posts: 4
Default

I had the very same issue.. there are 5 things to check to ensure everything is working fine:
1- Calibrate the Acelerometer
2- Verify the Motor Rotation
3- Check the Propellers
4- Configure PID parameters
5- Double-Check Connections

Actually created a video on how to solve the issue but the page is not allowing me to post the link :-(
erpoyo is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service