Go Back  R/C Tech Forums > General Forums > RC Boating
questions on aquacraft motley crew >

questions on aquacraft motley crew

questions on aquacraft motley crew

Reply

Old 08-22-2014, 08:41 PM
  #1  
Tech Apprentice
Thread Starter
iTrader: (1)
 
mwallin85's Avatar
 
Join Date: Apr 2010
Posts: 99
Trader Rating: 1 (100%+)
Default questions on aquacraft motley crew

Let me start by saying I'm a total newb when it comes to boats. Been into cars and planes for 15+ years. I picked up a used motley crew boat off a local racer for cheap. I know the guy real well so I trust the boat was as nice as he said. Well I've had it for over a year now and finally got the bug to try it tonight. Ran good and was actually more fun then i expected. After my first run I noticed the lipos were rather hot. I didn't have my temp gun but from touching them they were warmer then I've ever had them. Motor was warm also but not too worried about that. ESC was cool also. I'm using fantom racing 65c 6900mah, both are less them 6 months old and never puffed. My question is this normal or am I missing something. Boat is 100% stock, drive cable was lubed and wasn't bent. Water cooling system had water. Could it be my driving? I was giving it full throttle maybe 50% of the time and doing a lot of slower passes and a lot of on and off the power. Any ideas would be great and was as any other helpful info.

Thanks
mwallin85 is offline  
Reply With Quote
Old 08-24-2014, 11:16 AM
  #2  
Moderator
iTrader: (76)
 
roadrashracing's Avatar
 
Join Date: Nov 2005
Location: Green Bay, Wi
Posts: 13,076
Trader Rating: 76 (100%+)
Default

You can only run electric boats for 4-5 min depending on lipos, the draw lots of power.
roadrashracing is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service