Go Back  R/C Tech Forums > General Forums > RC Boating
Videoray thrusters with Ice2 Hv60 >

Videoray thrusters with Ice2 Hv60

Videoray thrusters with Ice2 Hv60

Reply

Old 02-11-2014, 06:23 AM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Feb 2014
Posts: 1
Questions?? Videoray thrusters with Ice2 Hv60

Hello RC-nutters,

I'm currently working on a project that includes a DX6i transmitter, 2 Videoray thrusters, 2 12 Volts lead batteries in series (24V) and 2 Phoenix Ice2 HV60.

The issue at hand: Everything is connected and up and running. Unfortunately my 200W thrusters only seem to deliver around 25W. As far as I can tell, the DX6i is set up correctly. The throttle setting is trimmed to max on both low and high.

I did read that they recommend the use of LiPo batteries in the Phoenix manual - but using larger Lead batteries shouldn't be a problem as far as I know.

I have yet to check the current limiting setting on the Phoenix ESC...

any thoughts??
wet ears is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service