Go Back  R/C Tech Forums > General Forums > Radio and Electronics
TRS-403SSi Receiver bad? Won't bind. >

TRS-403SSi Receiver bad? Won't bind.

TRS-403SSi Receiver bad? Won't bind.

Old 01-09-2016, 12:51 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Jan 2016
Posts: 2
Default TRS-403SSi Receiver bad? Won't bind.

New here and new to this awesome sport and hobby. I have a new SC10 RTR. NiMh battery pack. The truck ran great for about 5 minutes when I first got it going, charged the battery overnight until it FINALLY showed a full charge then nothing. Truck wont do anything. Tried to bind per instructions, nada. Took it to the local shop and guys knew their stuff and they think the receiver is bad. When I try to bind it, the receiver just blinks really quick one time and can never get into bind mode. We unplugged all channels and ran power straight to receiver and couldn't get it to bind, never got a red/green light combo, no light for that matter. Battery was tested and charging fully. The ESC just blinks a slow red seeming to indicate no talk from the receiver. I plan to call AE on Monday but wondered if anyone had any other ideas or ran into this. Searched and couldn't find another post but surely someone has a conclusive idea. Thanks!
haCk4PAr is offline  
Old 01-09-2016, 01:29 PM
  #2  
Tech Champion
 
Join Date: Oct 2007
Posts: 7,342
Default

Make sure the throttle trim on the transmitter is centered/at 0?
Dave H is offline  
Old 01-09-2016, 01:36 PM
  #3  
Tech Rookie
Thread Starter
 
Join Date: Jan 2016
Posts: 2
Default

Originally Posted by Dave H
Make sure the throttle trim on the transmitter is centered/at 0?
Thanks. It is set to 0. The issue seems to be the receiver is dead. When I power it on it blinks once and then done. Doesn't seem it ever gets in bind mode.
haCk4PAr is offline  
Old 01-09-2016, 01:41 PM
  #4  
Tech Champion
 
Join Date: Oct 2007
Posts: 7,342
Default

Bummer. If your dealer can't help call Associated, their service is good.
Dave H is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.