Go Back  R/C Tech Forums > General Forums > Radio and Electronics
Gens Ace connectors came loose inside case >

Gens Ace connectors came loose inside case

Gens Ace connectors came loose inside case

Old 06-30-2013, 05:43 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: May 2013
Location: SF Bay Area
Posts: 8
Default Gens Ace connectors came loose inside case

Hi, I have 2 Gens Ace 5000 4s 40c hard case batteries. A few weeks back the middle wire of the balance ports came loose in one of the batteries. I opened up the hard case (very carefully) and successfully managed to resolder the loose wire.

Now, the other battery has the same problem (wire from balance port came loose) and in addition, the thin foil that connects the 12AWG red (+ve) cable to the battery broke. I was surprised at how thin the foil is. Anyways, any hints on how I can reconnect the 12AWG cable back to the cell? All cells are in perfect condition so it would be a waste to throw away this battery.

Thanks!
Attached Thumbnails Gens Ace connectors came loose inside case-photo.jpg  
TheMartian is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.