Castle MMP sparks!!

Reply

Old 06-21-2012, 08:49 AM
  #1  
Tech Master
Thread Starter
iTrader: (55)
 
Join Date: Jan 2012
Posts: 1,131
Trader Rating: 55 (97%+)
Default Castle MMP sparks!!

My Castle MMP always sparks whenever I plug in the battery. I did the soldering myself and have had to swap connectors twice due to other issues.
Why is it still sparking? What can be wrong?
shagnat is offline  
Reply With Quote
Old 06-21-2012, 09:00 AM
  #2  
Tech Master
 
rcduder's Avatar
 
Join Date: Oct 2011
Location: Tacoma, WA
Posts: 1,124
Default

Originally Posted by shagnat View Post
My Castle MMP always sparks whenever I plug in the battery. I did the soldering myself and have had to swap connectors twice due to other issues.
Why is it still sparking? What can be wrong?
is it a little spark when you first plug it in and then its fine? Or is it a big spark that makes it so you cant even plug it in?
rcduder is offline  
Reply With Quote
Old 06-21-2012, 10:16 AM
  #3  
Tech Adept
iTrader: (1)
 
Join Date: Jun 2012
Location: Fresno, CA
Posts: 100
Trader Rating: 1 (100%+)
Default

Forgot what cause it but have read It's normal..
kingkong559 is offline  
Reply With Quote
Old 06-21-2012, 11:10 AM
  #4  
Tech Master
 
rcduder's Avatar
 
Join Date: Oct 2011
Location: Tacoma, WA
Posts: 1,124
Default

Originally Posted by kingkong559 View Post
Forgot what cause it but have read It's normal..
yeah im pretty sure that's true mine does that sometimes as well, it happens when one of the connectors is connected before the other one even by the slightest bit of time it sparks a little.
rcduder is offline  
Reply With Quote
Old 06-21-2012, 11:26 AM
  #5  
dtr
Tech Master
 
dtr's Avatar
 
Join Date: May 2011
Location: budapest, hungary
Posts: 1,544
Default

The spark is caused by the quick charging of the input capacitors, its perfectly normal.
dtr is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service