Go Back  R/C Tech Forums > General Forums > Radio and Electronics
Team Checkpoint tc-1030 charger problem >

Team Checkpoint tc-1030 charger problem

Team Checkpoint tc-1030 charger problem

Reply

Old 01-01-2012, 11:41 PM
  #1  
Tech Apprentice
Thread Starter
iTrader: (8)
 
cutsforth693doa's Avatar
 
Join Date: Nov 2008
Posts: 85
Trader Rating: 8 (100%+)
Default Team Checkpoint tc-1030 charger problem

Wanted to know if anyone had this problem. Trying to charge. Everythig goes fine but amps stay at 0 and so does the mah. No errors come up it does battery check and balencer lights up just like normal just no current.
Thanks for any help
cutsforth693doa is offline  
Reply With Quote
Old 01-02-2012, 05:57 PM
  #2  
Tech Lord
iTrader: (21)
 
Join Date: Jul 2008
Location: Houston, TX
Posts: 11,530
Trader Rating: 21 (100%+)
Default

Never had probs with mine, but the Ice charger I replaced with the TC did similar thing and it was done, I sent it in for repair and it wasn't worth the estimated repair costs.


Any chance it's still in warranty?
Duster_360 is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service