Go Back  R/C Tech Forums > General Forums > Radio and Electronics
Novak Havoc Pro Cutting Out Problem >

Novak Havoc Pro Cutting Out Problem

Novak Havoc Pro Cutting Out Problem

Old 12-28-2011, 08:51 AM
  #31  
Company Representative
 
Join Date: Jun 2005
Location: SoCal
Posts: 2,891
Default

Originally Posted by Jeauxkor View Post
I purchased a new havoc pro sc/8.5 motor/esc combo and a havoc pro sc by itself brand new from A main. Both worked fine, calibrated fine, everything seemed fine. About two packs in on the motor esc combo I started getting the locked rotor fault. So it went on the shelf until I could have it fixed. Then my other Havoc pro sc esc, with about two packs on it on a totally different motor, radio, chassis, battery etc. started having the rotor lock fault also. They didnt get run enough to even be dirty and are both DONE!! Im pretty dissapointed. My first time purchasing Novak by the way.
You can return these under warranty, if they are new. All warranty info and return forms are linked from our Customer Service page:

TeamNovak Customer Service
NovakTwo is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.