R/C Tech Forums

R/C Tech Forums (https://www.rctech.net/forum/)
-   Radio and Electronics (https://www.rctech.net/forum/radio-electronics-137/)
-   -   Anyone Help with Airtronics M11? FUSE? (https://www.rctech.net/forum/radio-electronics/321851-anyone-help-airtronics-m11-fuse.html)

hemi4me 08-23-2009 09:18 AM

Anyone Help with Airtronics M11? FUSE?
 
Hello, I have a problem with a brand new M11. I used it one night perfectly fine... Then I charged up a lipo and its POSSIBLE that I reversed the wires when plugging it in. I did not see smoke, it smells fine, there was no pop there was nothing. It will not power on even with the regular battery tray now.

I talked to a pro driver last night that said he thinks there is a internal fuse that can be replaced. Anyone have any knowledge of this? Anyone had a similar problem?

I just can't believe its toasted without the thing smoking or popping or simply doing something strange. Its almost as if there is nothing connected in the battery its dead.

I have the receipt and its only been a month or so since I bought it, but I hear Airtronics takes forever to fix and or return things. If anyone at all can help I would appreciate it much.

<PsOp> 08-23-2009 03:47 PM

I have the same problem, m11 has no power. Tried lipo and battery tray both did not work and my radio was working fine yesterday and its only two months old :weird:

hemi4me 08-24-2009 08:51 PM

UNREAL...

I had the fuse fixed...

I brought it home, before putting it all back together I tested it with the 8 aa.

Worked perfect.

I put it all back together and it was a bitch.

Worked fine...

I put the lipo in 11.1 V said it was for the m11.

Worked fine... Turned it off finished the last touches.

Again tried to power it on, same thing blows again I guess. Nothing now. No power yet again.

I assume that the radio does not like the lipo?


All times are GMT -7. It is currently 12:50 AM.

Powered By: vBulletin v3.9.3.8
Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.